summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-07 17:07:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-07 17:32:48 +0200
commit419e31d8342ca3f5b236f7ef6437bfdcfe2bbac4 (patch)
tree4f7acd86e397296c5416483aa55c7e722fcbb066 /dev-ros
parentdev-ros/test_rosmaster: Remove old (diff)
downloadgentoo-419e31d8342ca3f5b236f7ef6437bfdcfe2bbac4.tar.gz
gentoo-419e31d8342ca3f5b236f7ef6437bfdcfe2bbac4.tar.bz2
gentoo-419e31d8342ca3f5b236f7ef6437bfdcfe2bbac4.zip
dev-ros/test_rosmaster: fix tests
Closes: https://bugs.gentoo.org/624786 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/test_rosmaster/test_rosmaster-1.15.8.ebuild5
-rw-r--r--dev-ros/test_rosmaster/test_rosmaster-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-ros/test_rosmaster/test_rosmaster-1.15.8.ebuild b/dev-ros/test_rosmaster/test_rosmaster-1.15.8.ebuild
index 26a355408e51..6a163fb0f0ad 100644
--- a/dev-ros/test_rosmaster/test_rosmaster-1.15.8.ebuild
+++ b/dev-ros/test_rosmaster/test_rosmaster-1.15.8.ebuild
@@ -24,6 +24,11 @@ DEPEND="${RDEPEND}
mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}
+
src_install() {
ros-catkin_src_install
dodir /usr/share/${PN}
diff --git a/dev-ros/test_rosmaster/test_rosmaster-9999.ebuild b/dev-ros/test_rosmaster/test_rosmaster-9999.ebuild
index 26a355408e51..6a163fb0f0ad 100644
--- a/dev-ros/test_rosmaster/test_rosmaster-9999.ebuild
+++ b/dev-ros/test_rosmaster/test_rosmaster-9999.ebuild
@@ -24,6 +24,11 @@ DEPEND="${RDEPEND}
mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}
+
src_install() {
ros-catkin_src_install
dodir /usr/share/${PN}