summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-31 08:08:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-31 11:10:17 +0200
commit4445793c6d3543fa67c3c84d6b9988fd7f422ded (patch)
treedfaf6a52cfa3d8b49d046c1f849659bde014a63c /dev-ros
parentdev-ros/smclib: Bump to 1.8.6. (diff)
downloadgentoo-4445793c6d3543fa67c3c84d6b9988fd7f422ded.tar.gz
gentoo-4445793c6d3543fa67c3c84d6b9988fd7f422ded.tar.bz2
gentoo-4445793c6d3543fa67c3c84d6b9988fd7f422ded.zip
dev-ros/test_bond: Bump to 1.8.6.
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/test_bond/Manifest1
-rw-r--r--dev-ros/test_bond/test_bond-1.8.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/test_bond/Manifest b/dev-ros/test_bond/Manifest
index 03281d3410da..082e0cd638e0 100644
--- a/dev-ros/test_bond/Manifest
+++ b/dev-ros/test_bond/Manifest
@@ -1 +1,2 @@
DIST bond_core-1.8.5.tar.gz 33713 BLAKE2B c18d77ac0d8ccf717dc5eba28ae560d4ce07aa7e4b077be5c38f46bccfe5b9fc218f47b72a553605e6c25d2b79e15decfceab5ce8ad8b211c6b1a91ab05cf7ba SHA512 544c0abc2e77debc984fdf6941b8f44b2a77b37ee50b4fd27418a296e8c489f445285358e32cc723d47a75bf0e289c9d49133a096efdbed26a0a058f3ea06609
+DIST bond_core-1.8.6.tar.gz 33915 BLAKE2B 7d75a9fce73974f1ca131807b9f7e9084dc8204861d85a10f8bf38dacbbe2b25bdbad6d8719374b95f6fffb18f7078cdbabd3353487e8a96420b7afd7498fdcd SHA512 862f3779e7b63c462118b8d0d17ed405c914792bd6293e12b4dbf2499f459566669cb60d8c207e29e386e32a2065c5c0ac7a98c4372d4eded4f107c8537c9bbf
diff --git a/dev-ros/test_bond/test_bond-1.8.6.ebuild b/dev-ros/test_bond/test_bond-1.8.6.ebuild
new file mode 100644
index 000000000000..cd85cdd267fc
--- /dev/null
+++ b/dev-ros/test_bond/test_bond-1.8.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tests for bond, bondpy and bondcpp"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bondcpp
+ dev-ros/bondpy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}