summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-29 17:50:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-29 17:50:31 +0200
commit4a20ff3457061f541893ea2a34320272fb172f39 (patch)
tree8379efe2d4faae884ae59e21d1cc502c944aa0eb /dev-ros
parentsci-misc/ViSP-images: bump to 3.2.0 (diff)
downloadgentoo-4a20ff3457061f541893ea2a34320272fb172f39.tar.gz
gentoo-4a20ff3457061f541893ea2a34320272fb172f39.tar.bz2
gentoo-4a20ff3457061f541893ea2a34320272fb172f39.zip
dev-ros/laser_cb_detector: fix build with boost 1.70
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/laser_cb_detector/files/boost170.patch13
-rw-r--r--dev-ros/laser_cb_detector/laser_cb_detector-0.10.14.ebuild4
2 files changed, 15 insertions, 2 deletions
diff --git a/dev-ros/laser_cb_detector/files/boost170.patch b/dev-ros/laser_cb_detector/files/boost170.patch
new file mode 100644
index 000000000000..019a948be95c
--- /dev/null
+++ b/dev-ros/laser_cb_detector/files/boost170.patch
@@ -0,0 +1,13 @@
+Index: laser_cb_detector/CMakeLists.txt
+===================================================================
+--- laser_cb_detector.orig/CMakeLists.txt
++++ laser_cb_detector/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ cmake_minimum_required(VERSION 2.8.3)
+ project(laser_cb_detector)
+
+-find_package(Boost REQUIRED signals thread)
++find_package(Boost REQUIRED thread)
+ find_package(catkin REQUIRED actionlib actionlib_msgs cv_bridge image_cb_detector message_filters roscpp settlerlib std_msgs)
+
+ add_action_files(DIRECTORY action FILES Config.action)
diff --git a/dev-ros/laser_cb_detector/laser_cb_detector-0.10.14.ebuild b/dev-ros/laser_cb_detector/laser_cb_detector-0.10.14.ebuild
index 605a596b776e..888eec2019d8 100644
--- a/dev-ros/laser_cb_detector/laser_cb_detector-0.10.14.ebuild
+++ b/dev-ros/laser_cb_detector/laser_cb_detector-0.10.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -27,4 +27,4 @@ RDEPEND="
dev-ros/settlerlib
"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gcc6.patch" )
+PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/boost170.patch" )