summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-14 12:06:04 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-14 12:06:04 +0100
commit4cf55addd17c412d8b9b065316f0af652eb64a3e (patch)
tree59cb9448b46a3183d687735b527e9562dd3ba1fa /dev-ros
parentdev-ros/test_rospy: Bump to 1.11.16. (diff)
downloadgentoo-4cf55addd17c412d8b9b065316f0af652eb64a3e.tar.gz
gentoo-4cf55addd17c412d8b9b065316f0af652eb64a3e.tar.bz2
gentoo-4cf55addd17c412d8b9b065316f0af652eb64a3e.zip
dev-ros/test_rosservice: Bump to 1.11.16.
Package-Manager: portage-2.2.24 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/test_rosservice/Manifest1
-rw-r--r--dev-ros/test_rosservice/test_rosservice-1.11.16.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/test_rosservice/Manifest b/dev-ros/test_rosservice/Manifest
index 898e47a6b524..1e41e2eb115c 100644
--- a/dev-ros/test_rosservice/Manifest
+++ b/dev-ros/test_rosservice/Manifest
@@ -1,2 +1,3 @@
DIST ros_comm-1.11.14.tar.gz 945041 SHA256 8e7beff35711b1918501c69cca4f29648d4d4207878edab069bcd59d515c78f3 SHA512 be768faa0a2f45c464e963934a95dc617cac6c3fcec2388602a27846774c25b882b5139099ce10d1d051a21d5938819942e079836d14618071bc7ad90ee78bab WHIRLPOOL e047ce984086655294c20dbf0715cc29f51ec358f075f02de80c5de0d4ef8059990dc8312d78d7a7fa91c4a974dc21cba15d6eacafe02fd3df527770e50f75a5
DIST ros_comm-1.11.15.tar.gz 946139 SHA256 532b8cc764e9ca8765484a4468b8537c1ddd84342896267cf3e9f6b19c1b7203 SHA512 8eea3fc948093a7640851f18856f2a20748afb80f935e28d230dc2095956d753bde5081dcd020d09638d9c5d63e031257515b6c6874286c03737507e67cce270 WHIRLPOOL 5e0a971f4312dce99c2e2c11841445cea999dbe5b1ebde3ce26badb9a7eaf9fb84220ed5d1e0088e85835104ddad3cd4d555708d010f83da6e84d257bafe699b
+DIST ros_comm-1.11.16.tar.gz 947310 SHA256 b8f48c57d58b623c0b9828476fd8fc785570238d1e117fddaae9aaf8600915d3 SHA512 a97678acbafbe33d063f2c69b42e11bc4815c18ba9bb701542fb272d95410d2c1c2a133aa40ad2211ea1b0c2535938a364adac8099b5231c50e37fa42fff5d3d WHIRLPOOL 16dbdb2f754f16ae73b989e443de9f9e4fdbea2f9411c63d02a53a46517fb565dd97d5ea2b155833bcd592d7e9dd23ae3e7676dd1a49ea3dd509ab47f28082f2
diff --git a/dev-ros/test_rosservice/test_rosservice-1.11.16.ebuild b/dev-ros/test_rosservice/test_rosservice-1.11.16.ebuild
new file mode 100644
index 000000000000..2a35b10b96ff
--- /dev/null
+++ b/dev-ros/test_rosservice/test_rosservice-1.11.16.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"