summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-20 11:56:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-20 14:43:58 +0200
commit5aba71a20527bfb1bc5919473d2b1b025523d908 (patch)
treeca152bb3aaab6585ae6e444998c36958a27e9ca2 /dev-ros
parentdev-ros/test_rosbag_storage: Bump to 1.15.9. (diff)
downloadgentoo-5aba71a20527bfb1bc5919473d2b1b025523d908.tar.gz
gentoo-5aba71a20527bfb1bc5919473d2b1b025523d908.tar.bz2
gentoo-5aba71a20527bfb1bc5919473d2b1b025523d908.zip
dev-ros/test_roscpp: Bump to 1.15.9.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/test_roscpp/Manifest1
-rw-r--r--dev-ros/test_roscpp/test_roscpp-1.15.9.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/test_roscpp/Manifest b/dev-ros/test_roscpp/Manifest
index adf4f2af1194..e01f0dcf16ba 100644
--- a/dev-ros/test_roscpp/Manifest
+++ b/dev-ros/test_roscpp/Manifest
@@ -1,2 +1,3 @@
DIST ros_comm-1.15.7.tar.gz 1080092 BLAKE2B d5c0dd1f54eac7aa11be21bbc680f85f988cc9328382c0c675b7d5986e888be603ed82affa5f51a270974d07044debe3ecf86f5647fd59cb29e8e791a227feb9 SHA512 67dc100e8ed03a25ea228cc7d456ec2203324098f9e11c9a249299df73bfc34efc75b1221c0fb6fceb38fece627f1dc5f2c23be93c9a1c85b1075784a45ff20e
DIST ros_comm-1.15.8.tar.gz 1080826 BLAKE2B c1a1e085225a96cf0b50309cb78e1ccdabefce1f23ee669393b7fc747537c7e39bfb6ad382b0d24e3b5507b1d0f3eaf2051a1bee90507b0e724e06a83df301a2 SHA512 b1c34ab6548400fc014eda496e5d1e1c7d134b9062a031386ac4eac3245ca83b034f74f0a189ccf9ec6933c18d6df0ae1a93d05f1526d09debf70c25aa25b6b9
+DIST ros_comm-1.15.9.tar.gz 1087337 BLAKE2B 8c1582425770eee7898de42785c620c5fe82e31764d8947c16f9dbb43dd03d0201344e72d5a24911f7cc3cf4eacd51d6fc2940cc2346b635a2c769b055898297 SHA512 3f009a29d74dd74169585afb8d08c41faa19128e384ef6aa6c7bf58ae4d31345e4ea5441fc99a81b7742f724df7c7e3c16c4e51473c4fddeb4b9b6bf41cff04b
diff --git a/dev-ros/test_roscpp/test_roscpp-1.15.9.ebuild b/dev-ros/test_roscpp/test_roscpp-1.15.9.ebuild
new file mode 100644
index 000000000000..6162bbe7696c
--- /dev/null
+++ b/dev-ros/test_roscpp/test_roscpp-1.15.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for roscpp"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=[threads]
+ test? (
+ dev-cpp/gtest
+ )
+"
+REQUIRED_USE="test? ( ros_messages_cxx )"
+PATCHES=( "${FILESDIR}/tests.patch" )
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ # Sometimes high number of tests running in parallel make them fail
+ # https://bugs.gentoo.org/738620
+ ros-catkin_src_test -j 1
+}