summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-09-03 18:41:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-09-03 18:48:03 +0200
commit656cfc1778f3d3f60c928cfdaa848d01426665a9 (patch)
tree86ff1ab2ae813bc88a4c2813176877f4ab92fbe0 /dev-ros
parentsys-kernel/bliss-initramfs: bumping to 9.2.0 (diff)
downloadgentoo-656cfc1778f3d3f60c928cfdaa848d01426665a9.tar.gz
gentoo-656cfc1778f3d3f60c928cfdaa848d01426665a9.tar.bz2
gentoo-656cfc1778f3d3f60c928cfdaa848d01426665a9.zip
dev-ros/test_tf2: Bump to 0.7.5.
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/test_tf2/Manifest1
-rw-r--r--dev-ros/test_tf2/test_tf2-0.7.5.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/test_tf2/Manifest b/dev-ros/test_tf2/Manifest
index 4e3cdf274309..c9c9144e6ab7 100644
--- a/dev-ros/test_tf2/Manifest
+++ b/dev-ros/test_tf2/Manifest
@@ -1,2 +1,3 @@
DIST geometry2-0.7.2.tar.gz 174319 BLAKE2B 0f319055cf0a4c8a425c31abc981ee1aee3c77b9dae8e0ddae6a0c4bdf09c31373b8005cb05177374ae5a2139c0f49a4cfdd5b966f8e991827ca2c6e471dcdd2 SHA512 8c2ad4e67d4d7509c3d9a7ef781d454eeb570fbc29d201ece7d2613258b7bed2ba00398655901e2b5856b59acad94422dbb6ae1f0bd545b3a41353204c31d00b
DIST geometry2-0.7.3.tar.gz 175974 BLAKE2B a0edbeea6db30f07d5cf6ddd4d0a8a1ce0221c8b0ad01929aa6a73a7a49e2e5bd08dfd01cef6cd964ea93b6e8f5aa1dd6ec395e8e4bbafa1117eb3436cae9c10 SHA512 20d207218000905a17411ee9c662778b3022481e84b903ca616cdfc439b2af55c7182988dc843103edc471d564e988fa311be916d0810ec86228585500ed532e
+DIST geometry2-0.7.5.tar.gz 176126 BLAKE2B 56f2062ca86b3573e9df59df4c400fd5eee35c7e30abb1f0d94b1e117a224fcb1272eaf9de14dc257d8c8438a414fd8d121d314e560e6712ca4db0da190075d5 SHA512 b3413282d2ad0aae54b0093607eee106cdd7ed23f4e5fbb1728ed4f848ee081257b9217696301e9f7860369dc98679d8abff12213ff3a69b39b061f02f5da8c9
diff --git a/dev-ros/test_tf2/test_tf2-0.7.5.ebuild b/dev-ros/test_tf2/test_tf2-0.7.5.ebuild
new file mode 100644
index 000000000000..24179b340482
--- /dev/null
+++ b/dev-ros/test_tf2/test_tf2-0.7.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 unit tests"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf
+ dev-ros/tf2
+ dev-ros/tf2_bullet
+ dev-ros/tf2_ros[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_kdl[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_msgs
+ dev-ros/rosbash
+ sci-libs/orocos_kdl
+ $(python_gen_cond_dep "dev-python/python_orocos_kdl[\${PYTHON_USEDEP}]")
+ dev-libs/boost:=[threads]
+ dev-cpp/gtest
+"
+
+mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )