summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-15 17:49:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-15 18:57:09 +0200
commit6fa3cb2fd5d55f26f1601d10806718b95d67ab1c (patch)
treeb57deca4c193bbfccd9e0794b4787d5141eea4e6 /dev-ros
parentdev-ros/rosauth: Remove old (diff)
downloadgentoo-6fa3cb2fd5d55f26f1601d10806718b95d67ab1c.tar.gz
gentoo-6fa3cb2fd5d55f26f1601d10806718b95d67ab1c.tar.bz2
gentoo-6fa3cb2fd5d55f26f1601d10806718b95d67ab1c.zip
dev-ros/ros_environment: bump to 1.3.1
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ros_environment/Manifest1
-rw-r--r--dev-ros/ros_environment/ros_environment-1.3.1.ebuild24
-rw-r--r--dev-ros/ros_environment/ros_environment-9999.ebuild3
3 files changed, 26 insertions, 2 deletions
diff --git a/dev-ros/ros_environment/Manifest b/dev-ros/ros_environment/Manifest
index f557152cca0e..742af0b8b37d 100644
--- a/dev-ros/ros_environment/Manifest
+++ b/dev-ros/ros_environment/Manifest
@@ -1 +1,2 @@
DIST ros_environment-1.2.0.tar.gz 6366 BLAKE2B ff540b9e861d039739253b9effbfe06ec703f47b48d9bb7009b5caed5010ed8219a207bfd363c03b115d018965c2e584abbf58f649ea868e66e79d4dda11d1ae SHA512 1b89e3d6ea88fc0972bbe980bae0b663e9335adece8eb0d517cac76b0a412cbe6b9783a967d4a9b5ca1c3bf2a432bb826d28f6f1d9a33fcc33a75edeef0be20b
+DIST ros_environment-1.3.1.tar.gz 6533 BLAKE2B 50b6b24af91c5d96097873c3a05f258b2737053594a888ac5677147160708e192e1662558f33537b9510d206d5f00374ba3bec3b3491e5f51cfac3bcec842c1f SHA512 f47b9a7801ea4aa841b5127714e099c83e60fb42e8eedb726a4d3b23fcfb93c25c6f9bdc042a449399333c3165db1a72b9ebb25424981fe43bcfa5445f4678c5
diff --git a/dev-ros/ros_environment/ros_environment-1.3.1.ebuild b/dev-ros/ros_environment/ros_environment-1.3.1.ebuild
new file mode 100644
index 000000000000..9b7f339511b4
--- /dev/null
+++ b/dev-ros/ros_environment/ros_environment-1.3.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_environment"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS environment variables"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="!!<dev-ros/roslib-1.14.3"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/catkinprefixpath.patch" )
+
+src_configure() {
+ export ROS_DISTRO="Gentoo"
+ export ROS_DISTRO_OVERRIDE="Gentoo"
+ ros-catkin_src_configure
+}
diff --git a/dev-ros/ros_environment/ros_environment-9999.ebuild b/dev-ros/ros_environment/ros_environment-9999.ebuild
index 1478d0978ba8..9b7f339511b4 100644
--- a/dev-ros/ros_environment/ros_environment-9999.ebuild
+++ b/dev-ros/ros_environment/ros_environment-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/ros_environment"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
inherit ros-catkin