summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-05-13 13:25:16 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-05-13 16:07:08 +0200
commit78373ad0c2a5bd7e1300ad01e5f2bb2c3fea6f7b (patch)
treeab5bde622886f91bc84253b69594560853e671d6 /dev-ros
parentdev-ros/roscpp: Bump to 1.15.4. (diff)
downloadgentoo-78373ad0c2a5bd7e1300ad01e5f2bb2c3fea6f7b.tar.gz
gentoo-78373ad0c2a5bd7e1300ad01e5f2bb2c3fea6f7b.tar.bz2
gentoo-78373ad0c2a5bd7e1300ad01e5f2bb2c3fea6f7b.zip
dev-ros/rospy: Bump to 1.15.4.
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rospy/Manifest1
-rw-r--r--dev-ros/rospy/rospy-1.15.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/rospy/Manifest b/dev-ros/rospy/Manifest
index 3d0a1ebaa18a..61884545d536 100644
--- a/dev-ros/rospy/Manifest
+++ b/dev-ros/rospy/Manifest
@@ -1 +1,2 @@
DIST ros_comm-1.14.3.tar.gz 1045287 BLAKE2B c079983aa730e70028d1bf2c365d01d99ce09ced0c0f6443b18f9d0fb83715f6af4b313d6db4eb99dcc10052c81fa3e6560e7b3591b2fbe14b9ec20fac24babe SHA512 52df24f10f476697ee6fa340da354b45431f35018a25e2674dc9306f175929a4b0368753503ea143f87aeb4945a2e67c37f83d833f54b53f9a76a81022c280a3
+DIST ros_comm-1.15.4.tar.gz 1071246 BLAKE2B 57867c192bfd48f3a0534762808c668031081a6155510879e68f9618226b9c5eff0d5fc9ec0e7ec8d0cc1f0d74794a4e55151036275ae6fc5bb613cc42137ddc SHA512 f92233cbf5ee97832023545730d3e756dfa08507072c074ac3e0763db1c2c2ab9fcbb0c90995a0c5d43f0ddc2ee528c185173a664b19abe4f8159aa3f3cb20dc
diff --git a/dev-ros/rospy/rospy-1.15.4.ebuild b/dev-ros/rospy/rospy-1.15.4.ebuild
new file mode 100644
index 000000000000..ed13430b1e69
--- /dev/null
+++ b/dev-ros/rospy/rospy-1.15.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
+ROS_SUBDIR=clients/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roscpp[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ ros-catkin_src_install
+ # Other tests need these nodes
+ exeinto /usr/share/${PN}
+ doexe test_nodes/*
+}