summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-11 15:21:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-11 15:23:13 +0200
commit846ed0ec182233455a294e451c3cb66469a58e17 (patch)
treeb86bba92a7f81bef4f3f54e0310c751e41ee26c8 /dev-ros
parentdev-ros/roscpp_tutorials: Bump to 0.10.2. (diff)
downloadgentoo-846ed0ec182233455a294e451c3cb66469a58e17.tar.gz
gentoo-846ed0ec182233455a294e451c3cb66469a58e17.tar.bz2
gentoo-846ed0ec182233455a294e451c3cb66469a58e17.zip
dev-ros/rospy_tutorials: Bump to 0.10.2.
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rospy_tutorials/Manifest1
-rw-r--r--dev-ros/rospy_tutorials/rospy_tutorials-0.10.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/rospy_tutorials/Manifest b/dev-ros/rospy_tutorials/Manifest
index 82eb97f90c3c..b03baf6abde3 100644
--- a/dev-ros/rospy_tutorials/Manifest
+++ b/dev-ros/rospy_tutorials/Manifest
@@ -1 +1,2 @@
DIST ros_tutorials-0.10.1.tar.gz 159522 BLAKE2B b0e045c6ee62cb68dfa977d17125af23d8ef80a619e822d245531a6cb3520a4d53120769e74ae2ba9af2813ce968e0c4fb22b7655eadd13b1a720705a9f75374 SHA512 592edb84f2e0ea80b2757ae890f495e8cb93d867b1bc6d64e6446f28fcffbd48c05703ac30ac29fd184a689f465728a5958d8c747587c756b53341c1d0740684
+DIST ros_tutorials-0.10.2.tar.gz 159630 BLAKE2B 6b7ea4c0aba110b746052a42150dd4e9faedbb1e4ab5a44bbef7c1079192238ac22bb18fc9968ea9e4450dde47bf1f5b7dabc0788aa8c232dfef3d1039a63f2e SHA512 73b420acf20a468f51db891fe0b0b33c3c838ea6fab4c03faab9a7abedc3ee68ec27ef0e70869143d0a22941eb77bac1fc80542cc0c14988ff75cb9685c174c5
diff --git a/dev-ros/rospy_tutorials/rospy_tutorials-0.10.2.ebuild b/dev-ros/rospy_tutorials/rospy_tutorials-0.10.2.ebuild
new file mode 100644
index 000000000000..ecde7b0dc1db
--- /dev/null
+++ b/dev-ros/rospy_tutorials/rospy_tutorials-0.10.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/ros_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to show the features of ROS step-by-step"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roscpp_tutorials
+ )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}