summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-10 18:20:35 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-10 18:21:00 +0100
commit869ad6e1ce4f2ccdc6ae39f8a54fa682d586ec0e (patch)
tree7655716d028f9b0a0f19c4e369e98416daec35bf /dev-ros
parentdev-ros/camera_calibration_parsers: Set proper python dependencies, bug #608330 (diff)
downloadgentoo-869ad6e1ce4f2ccdc6ae39f8a54fa682d586ec0e.tar.gz
gentoo-869ad6e1ce4f2ccdc6ae39f8a54fa682d586ec0e.tar.bz2
gentoo-869ad6e1ce4f2ccdc6ae39f8a54fa682d586ec0e.zip
dev-ros/camera_calibration_parsers: Fix build with python 3 and enable python 3.4/3.5.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.12.ebuild3
-rw-r--r--dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild3
-rw-r--r--dev-ros/camera_calibration_parsers/files/boostpython.patch20
3 files changed, 24 insertions, 2 deletions
diff --git a/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.12.ebuild b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.12.ebuild
index 36edaa11f6ed..3e0a75d86d8b 100644
--- a/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.12.ebuild
+++ b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.12.ebuild
@@ -6,7 +6,7 @@ EAPI=5
ROS_REPO_URI="https://github.com/ros-perception/image_common"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
inherit ros-catkin
@@ -25,3 +25,4 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-python/nose )
"
+PATCHES=( "${FILESDIR}/boostpython.patch" )
diff --git a/dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild
index 36edaa11f6ed..3e0a75d86d8b 100644
--- a/dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild
+++ b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=5
ROS_REPO_URI="https://github.com/ros-perception/image_common"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
inherit ros-catkin
@@ -25,3 +25,4 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-python/nose )
"
+PATCHES=( "${FILESDIR}/boostpython.patch" )
diff --git a/dev-ros/camera_calibration_parsers/files/boostpython.patch b/dev-ros/camera_calibration_parsers/files/boostpython.patch
new file mode 100644
index 000000000000..8e2b868ec452
--- /dev/null
+++ b/dev-ros/camera_calibration_parsers/files/boostpython.patch
@@ -0,0 +1,20 @@
+Revert special handling not needed on Gentoo.
+https://bugs.gentoo.org/show_bug.cgi?id=608330
+
+Index: camera_calibration_parsers/CMakeLists.txt
+===================================================================
+--- camera_calibration_parsers.orig/CMakeLists.txt
++++ camera_calibration_parsers/CMakeLists.txt
+@@ -4,11 +4,7 @@ project(camera_calibration_parsers)
+ find_package(catkin REQUIRED sensor_msgs rosconsole roscpp roscpp_serialization)
+
+ find_package(PythonLibs REQUIRED)
+-if(PYTHONLIBS_VERSION_STRING VERSION_LESS 3)
+- find_package(Boost REQUIRED COMPONENTS filesystem python)
+-else()
+- find_package(Boost REQUIRED COMPONENTS filesystem python3)
+-endif()
++find_package(Boost REQUIRED COMPONENTS filesystem python)
+ include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
+
+ catkin_python_setup()