summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-04-14 14:57:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-04-14 14:57:12 +0200
commit9da83eff3163fcb0147d70e90b298603187a8db4 (patch)
tree0e38b94a0deefdb5def22962a6a62691b7697646 /dev-ros
parentdev-python/rospkg: Remove old (diff)
downloadgentoo-9da83eff3163fcb0147d70e90b298603187a8db4.tar.gz
gentoo-9da83eff3163fcb0147d70e90b298603187a8db4.tar.bz2
gentoo-9da83eff3163fcb0147d70e90b298603187a8db4.zip
dev-ros/hector_map_tools: add missing eigen dep
Closes: https://bugs.gentoo.org/715638 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/hector_map_tools/hector_map_tools-0.4.0-r1.ebuild (renamed from dev-ros/hector_map_tools/hector_map_tools-0.4.0.ebuild)7
-rw-r--r--dev-ros/hector_map_tools/hector_map_tools-9999.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/dev-ros/hector_map_tools/hector_map_tools-0.4.0.ebuild b/dev-ros/hector_map_tools/hector_map_tools-0.4.0-r1.ebuild
index cafea00cc37b..298849dc5dfa 100644
--- a/dev-ros/hector_map_tools/hector_map_tools-0.4.0.ebuild
+++ b/dev-ros/hector_map_tools/hector_map_tools-0.4.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,5 +13,8 @@ LICENSE="BSD"
SLOT="0"
IUSE=""
-RDEPEND="dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]"
+RDEPEND="
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3
+"
DEPEND="${RDEPEND}"
diff --git a/dev-ros/hector_map_tools/hector_map_tools-9999.ebuild b/dev-ros/hector_map_tools/hector_map_tools-9999.ebuild
index 2257b6d50ad9..298849dc5dfa 100644
--- a/dev-ros/hector_map_tools/hector_map_tools-9999.ebuild
+++ b/dev-ros/hector_map_tools/hector_map_tools-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,5 +13,8 @@ LICENSE="BSD"
SLOT="0"
IUSE=""
-RDEPEND="dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]"
+RDEPEND="
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3
+"
DEPEND="${RDEPEND}"