summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-03 13:02:08 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-03 13:21:48 +0200
commita91f0076adee35958c32e732b6826db0ed10e190 (patch)
tree934784023fa1111a07f3fbf597877c93b95ac3f2 /dev-ros
parentdev-ros/rosconsole: update to new split repo (diff)
downloadgentoo-a91f0076adee35958c32e732b6826db0ed10e190.tar.gz
gentoo-a91f0076adee35958c32e732b6826db0ed10e190.tar.bz2
gentoo-a91f0076adee35958c32e732b6826db0ed10e190.zip
dev-ros/rosconsole: bump to 1.13.7
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rosconsole/Manifest1
-rw-r--r--dev-ros/rosconsole/rosconsole-1.13.7.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ros/rosconsole/Manifest b/dev-ros/rosconsole/Manifest
index a678ef37f71e..76044d69e5bc 100644
--- a/dev-ros/rosconsole/Manifest
+++ b/dev-ros/rosconsole/Manifest
@@ -1 +1,2 @@
DIST ros_comm-1.13.6.tar.gz 1047870 BLAKE2B 874e31faa1a6a77292dab4b7fa64ed13a1f1f63f76512ea351e53bd14ce87662cea5c648e48c3c16668104129cc5eb172bc8f381516bdba676c7212f1acbaaf9 SHA512 382e81847141ab95462fc84a8215b945af995d29f9c0d507665e22faaf79aee9789950546ca7737bd40059f3ed1ecd284ff11bd3e6f1732f3c47a433c5d25155
+DIST rosconsole-1.13.7.tar.gz 24202 BLAKE2B bee6d4a9a682fe045a233989373e8a283c26d85bd4d746c2363798cd61f168e368afef81872437363b55a44080e6c926b4f3fd9c66fa9e2bf078454a675336ea SHA512 e0e17641011de5a3b58ddc7ac984042463f375f76174ff6bfa8a6c95d7889e33e702156f7ec0d7628f9f37a1d062f0291367ee81025dd9989320d5d24c35b387
diff --git a/dev-ros/rosconsole/rosconsole-1.13.7.ebuild b/dev-ros/rosconsole/rosconsole-1.13.7.ebuild
new file mode 100644
index 000000000000..184a614f8a0c
--- /dev/null
+++ b/dev-ros/rosconsole/rosconsole-1.13.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rosconsole"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS console output library"
+LICENSE="BSD"
+SLOT="0"
+IUSE="+log4cxx glog"
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/rosunit
+ dev-libs/boost:=[threads]
+ log4cxx? ( dev-libs/log4cxx )
+ !log4cxx? ( glog? ( dev-cpp/glog ) )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local ROSCONSOLE_BACKEND=""
+ if use log4cxx; then
+ ROSCONSOLE_BACKEND="log4cxx"
+ elif use glog; then
+ ROSCONSOLE_BACKEND="glog"
+ else
+ ROSCONSOLE_BACKEND="print"
+ fi
+ local mycatkincmakeargs=( "-DROSCONSOLE_BACKEND=${ROSCONSOLE_BACKEND}" )
+ ros-catkin_src_configure
+}