summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-20 13:37:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-20 14:44:01 +0200
commitb318e036cb86785d19968a4f00a0162218768fd1 (patch)
tree29c9d246dbd74f7eb0b1cdbbefc2881bcaf23c57 /dev-ros
parentdev-util/rosinstall_generator: fix distutils dep (diff)
downloadgentoo-b318e036cb86785d19968a4f00a0162218768fd1.tar.gz
gentoo-b318e036cb86785d19968a4f00a0162218768fd1.tar.bz2
gentoo-b318e036cb86785d19968a4f00a0162218768fd1.zip
dev-ros/rosmsg: fix for duplicate packages in show
Fix tests. Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rosmsg/files/duplicates.patch13
-rw-r--r--dev-ros/rosmsg/rosmsg-1.15.9.ebuild6
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-ros/rosmsg/files/duplicates.patch b/dev-ros/rosmsg/files/duplicates.patch
new file mode 100644
index 000000000000..4705f00d2e85
--- /dev/null
+++ b/dev-ros/rosmsg/files/duplicates.patch
@@ -0,0 +1,13 @@
+Index: rosmsg/src/rosmsg/__init__.py
+===================================================================
+--- rosmsg.orig/src/rosmsg/__init__.py
++++ rosmsg/src/rosmsg/__init__.py
+@@ -618,7 +618,7 @@ def rosmsg_cmd_show(mode, full, alias='s
+ if '/' in arg: #package specified
+ rosmsg_debug(rospack, mode, arg, options.raw)
+ else:
+- found_msgs = list(rosmsg_search(rospack, mode, arg))
++ found_msgs = list(dict.fromkeys(rosmsg_search(rospack, mode, arg)))
+ if not found_msgs:
+ print("Could not find msg '%s'" % arg, file=sys.stderr)
+ return 1
diff --git a/dev-ros/rosmsg/rosmsg-1.15.9.ebuild b/dev-ros/rosmsg/rosmsg-1.15.9.ebuild
index ba0d62bb080b..c750959458b6 100644
--- a/dev-ros/rosmsg/rosmsg-1.15.9.ebuild
+++ b/dev-ros/rosmsg/rosmsg-1.15.9.ebuild
@@ -23,3 +23,9 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}] )
"
+PATCHES=( "${FILESDIR}/duplicates.patch" )
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}/../../:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}