summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-20 11:55:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-20 14:43:57 +0200
commitba2445669f5c3c554b7b5bed419c3c44073c990d (patch)
tree6ca4b70bf03ca7da2e6ac4e7917e7f058f86ff0c /dev-ros
parentdev-ros/rostest: Bump to 1.15.9. (diff)
downloadgentoo-ba2445669f5c3c554b7b5bed419c3c44073c990d.tar.gz
gentoo-ba2445669f5c3c554b7b5bed419c3c44073c990d.tar.bz2
gentoo-ba2445669f5c3c554b7b5bed419c3c44073c990d.zip
dev-ros/rostopic: Bump to 1.15.9.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rostopic/Manifest1
-rw-r--r--dev-ros/rostopic/rostopic-1.15.9.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/rostopic/Manifest b/dev-ros/rostopic/Manifest
index 00d95d9416dc..fd3eb70a996d 100644
--- a/dev-ros/rostopic/Manifest
+++ b/dev-ros/rostopic/Manifest
@@ -1 +1,2 @@
DIST ros_comm-1.15.8.tar.gz 1080826 BLAKE2B c1a1e085225a96cf0b50309cb78e1ccdabefce1f23ee669393b7fc747537c7e39bfb6ad382b0d24e3b5507b1d0f3eaf2051a1bee90507b0e724e06a83df301a2 SHA512 b1c34ab6548400fc014eda496e5d1e1c7d134b9062a031386ac4eac3245ca83b034f74f0a189ccf9ec6933c18d6df0ae1a93d05f1526d09debf70c25aa25b6b9
+DIST ros_comm-1.15.9.tar.gz 1087337 BLAKE2B 8c1582425770eee7898de42785c620c5fe82e31764d8947c16f9dbb43dd03d0201344e72d5a24911f7cc3cf4eacd51d6fc2940cc2346b635a2c769b055898297 SHA512 3f009a29d74dd74169585afb8d08c41faa19128e384ef6aa6c7bf58ae4d31345e4ea5441fc99a81b7742f724df7c7e3c16c4e51473c4fddeb4b9b6bf41cff04b
diff --git a/dev-ros/rostopic/rostopic-1.15.9.ebuild b/dev-ros/rostopic/rostopic-1.15.9.ebuild
new file mode 100644
index 000000000000..c436e4f953a2
--- /dev/null
+++ b/dev-ros/rostopic/rostopic-1.15.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS Topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}