summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-03-15 17:27:51 +0100
committerAlexis Ballier <aballier@gentoo.org>2022-03-15 18:05:39 +0100
commitcd8c3b3bd92a7f93898bcc7baea88a3ac5f270b8 (patch)
tree40d7524d8a4a511bb3ba05f2ddce05818c76d281 /dev-ros
parentdev-ros/ament_cmake_target_dependencies: bump to 1.3.0 (diff)
downloadgentoo-cd8c3b3bd92a7f93898bcc7baea88a3ac5f270b8.tar.gz
gentoo-cd8c3b3bd92a7f93898bcc7baea88a3ac5f270b8.tar.bz2
gentoo-cd8c3b3bd92a7f93898bcc7baea88a3ac5f270b8.zip
dev-ros/ament_cmake_test: bump to 1.3.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_cmake_test/Manifest1
-rw-r--r--dev-ros/ament_cmake_test/ament_cmake_test-1.3.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_test/Manifest b/dev-ros/ament_cmake_test/Manifest
index 522fa62c10c1..ec48183d6431 100644
--- a/dev-ros/ament_cmake_test/Manifest
+++ b/dev-ros/ament_cmake_test/Manifest
@@ -1 +1,2 @@
DIST ament_cmake-1.1.4.tar.gz 94117 BLAKE2B 612bf25301b9794cf51b460819cf4a029547fbc97f7a428215a19f0a7747115de02d3f2cb5f5e524e73ba30813388ca7bff059ab7fe472916eaf2b23ecc76355 SHA512 56acd3d2a8d4b15a164dfdcaa2157fff2889a4c5c0b155ad65a815760f531cdf10226d158f40fc15660c52dd1585b85a2566e402f31881378351624f286efb3d
+DIST ament_cmake-1.3.0.tar.gz 103040 BLAKE2B 8220d380923a591667b3b4bbe785f30ac935ce10c4fd6bf8bd22149586373f353cd9e71723638dca503bd54ff709783ea1e133c5034901fe2d891fd6bbe7c560 SHA512 44f71102e22fe9f6cd8c3cc13960d63af377eec0a6f7fb7ae99c18f2afae07f3997c9f226f7db8cc8020acdf45561ad9eb1006c6834125d6da137e8638617df8
diff --git a/dev-ros/ament_cmake_test/ament_cmake_test-1.3.0.ebuild b/dev-ros/ament_cmake_test/ament_cmake_test-1.3.0.ebuild
new file mode 100644
index 000000000000..09ab66781bf4
--- /dev/null
+++ b/dev-ros/ament_cmake_test/ament_cmake_test-1.3.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to add tests in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ PROPERTIES="live"
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+ dev-ros/ament_cmake_core
+ dev-python/ament_package[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_python
+ ${PYTHON_DEPS}
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ python_foreach_impl cmake_src_configure
+}
+
+src_compile() {
+ python_foreach_impl cmake_src_compile
+}
+
+src_test() {
+ python_foreach_impl cmake_src_test
+}
+
+src_install() {
+ python_foreach_impl cmake_src_install
+ python_foreach_impl python_optimize
+}