summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-28 15:30:30 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-28 16:04:28 +0100
commite504013dc705a9ab392b14b65716f9b02833ad3c (patch)
treea828a47328e6d843c5d86902d39bbe272c65a09e /dev-ros
parentdev-ros/rviz: remove old (diff)
downloadgentoo-e504013dc705a9ab392b14b65716f9b02833ad3c.tar.gz
gentoo-e504013dc705a9ab392b14b65716f9b02833ad3c.tar.bz2
gentoo-e504013dc705a9ab392b14b65716f9b02833ad3c.zip
dev-ros/rospack: add custom patch to return proper package paths with our package.xml moved to ros_packages.
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rospack/files/gentoo.patch18
-rw-r--r--dev-ros/rospack/rospack-2.3.1-r1.ebuild (renamed from dev-ros/rospack/rospack-2.3.1.ebuild)1
-rw-r--r--dev-ros/rospack/rospack-9999.ebuild3
3 files changed, 21 insertions, 1 deletions
diff --git a/dev-ros/rospack/files/gentoo.patch b/dev-ros/rospack/files/gentoo.patch
new file mode 100644
index 000000000000..7090d7b02dd7
--- /dev/null
+++ b/dev-ros/rospack/files/gentoo.patch
@@ -0,0 +1,18 @@
+Index: rospack-2.3.1/src/rospack.cpp
+===================================================================
+--- rospack-2.3.1.orig/src/rospack.cpp
++++ rospack-2.3.1/src/rospack.cpp
+@@ -191,6 +191,13 @@ class Stackage
+ break;
+ }
+ }
++
++ // On Gentoo we move package.xml to /usr/share/ros_packages/... but need to keep standard stuff in /usr/share, so correct this here.
++ try {
++ fs::path p = fs::canonical("../../" + name_, path_);
++ path_ = p.string();
++ }
++ catch(fs::filesystem_error& e) {};
+ }
+
+ bool isStack() const
diff --git a/dev-ros/rospack/rospack-2.3.1.ebuild b/dev-ros/rospack/rospack-2.3.1-r1.ebuild
index 60535c584ae8..61b544e45a92 100644
--- a/dev-ros/rospack/rospack-2.3.1.ebuild
+++ b/dev-ros/rospack/rospack-2.3.1-r1.ebuild
@@ -17,6 +17,7 @@ DESCRIPTION="Retrieves information about ROS packages available on the filesyste
LICENSE="BSD"
SLOT="0"
IUSE=""
+PATCHES=( "${FILESDIR}/gentoo.patch" )
RDEPEND="dev-libs/boost:=
dev-libs/tinyxml
diff --git a/dev-ros/rospack/rospack-9999.ebuild b/dev-ros/rospack/rospack-9999.ebuild
index 4d7f1ab66b65..61b544e45a92 100644
--- a/dev-ros/rospack/rospack-9999.ebuild
+++ b/dev-ros/rospack/rospack-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,6 +17,7 @@ DESCRIPTION="Retrieves information about ROS packages available on the filesyste
LICENSE="BSD"
SLOT="0"
IUSE=""
+PATCHES=( "${FILESDIR}/gentoo.patch" )
RDEPEND="dev-libs/boost:=
dev-libs/tinyxml