summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-20 10:05:01 +0100
committerHans de Graaff <graaff@gentoo.org>2022-03-20 11:04:35 +0100
commite354a1b16faa8f6d5475e21d8737219e3994dbec (patch)
tree4c8788cd995a73057a469bed542555be118e975b /dev-ruby/abstract
parentdev-ruby/bacon: add ruby31 (diff)
downloadgentoo-e354a1b16faa8f6d5475e21d8737219e3994dbec.tar.gz
gentoo-e354a1b16faa8f6d5475e21d8737219e3994dbec.tar.bz2
gentoo-e354a1b16faa8f6d5475e21d8737219e3994dbec.zip
dev-ruby/abstract: add ruby31
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/abstract')
-rw-r--r--dev-ruby/abstract/abstract-1.0.0-r5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/abstract/abstract-1.0.0-r5.ebuild b/dev-ruby/abstract/abstract-1.0.0-r5.ebuild
new file mode 100644
index 000000000000..1febb53a86ce
--- /dev/null
+++ b/dev-ruby/abstract/abstract-1.0.0-r5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library which enable you to define abstract method in Ruby"
+HOMEPAGE="https://rubygems.org/gems/abstract"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test.rb || die "tests failed"
+}