summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-01-18 17:05:19 +0100
committerHans de Graaff <graaff@gentoo.org>2023-01-18 17:07:20 +0100
commit94906b86bb2610d1f3e529b78e4a721e5e332c86 (patch)
treed8178e15be7022020d57c66adbbd85daaa8635f3 /dev-ruby/actioncable/actioncable-7.0.4.1.ebuild
parentdev-ruby/activemodel: add 7.0.4.1 (diff)
downloadgentoo-94906b86bb2610d1f3e529b78e4a721e5e332c86.tar.gz
gentoo-94906b86bb2610d1f3e529b78e4a721e5e332c86.tar.bz2
gentoo-94906b86bb2610d1f3e529b78e4a721e5e332c86.zip
dev-ruby/actioncable: add 7.0.4.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actioncable/actioncable-7.0.4.1.ebuild')
-rw-r--r--dev-ruby/actioncable/actioncable-7.0.4.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/actioncable/actioncable-7.0.4.1.ebuild b/dev-ruby/actioncable/actioncable-7.0.4.1.ebuild
new file mode 100644
index 000000000000..b2c27ae6e548
--- /dev/null
+++ b/dev-ruby/actioncable/actioncable-7.0.4.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_EXTRAINSTALL="app"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Integrated WebSockets for Rails"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+# Tests require many new dependencies, skipping for now
+RESTRICT="test"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}:*
+ ~dev-ruby/activesupport-${PV}:*
+ dev-ruby/nio4r:2
+ >=dev-ruby/websocket-driver-0.6.1:*
+"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/railties-4.2.0
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.14.0:0.14
+ )"