summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-12-15 07:15:35 +0100
committerHans de Graaff <graaff@gentoo.org>2021-12-15 07:15:35 +0100
commit51a0dbd7c3047ad9d11cffaf458869ebbc68c3f5 (patch)
tree27b5958d3d8a567ea67af482622370f3a0dbf2a0 /dev-ruby/actionmailbox
parentdev-ruby/actiontext: add 6.1.4.3 (diff)
downloadgentoo-51a0dbd7c3047ad9d11cffaf458869ebbc68c3f5.tar.gz
gentoo-51a0dbd7c3047ad9d11cffaf458869ebbc68c3f5.tar.bz2
gentoo-51a0dbd7c3047ad9d11cffaf458869ebbc68c3f5.zip
dev-ruby/actionmailbox: add 6.1.4.3
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actionmailbox')
-rw-r--r--dev-ruby/actionmailbox/Manifest1
-rw-r--r--dev-ruby/actionmailbox/actionmailbox-6.1.4.3.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/actionmailbox/Manifest b/dev-ruby/actionmailbox/Manifest
index 44f32ff2ecd7..e69ae3f3fb9f 100644
--- a/dev-ruby/actionmailbox/Manifest
+++ b/dev-ruby/actionmailbox/Manifest
@@ -1,3 +1,4 @@
DIST rails-6.0.4.1.tgz 18595307 BLAKE2B 9a950a45cd04c5fe0cbe57fd014a6997074dcbe8f95fcbb2f5d3b6372867ef8bb0931b909ca8eba623787419f5f45504cdcd477729ba3b3a052f5003229121cd SHA512 322cfa6d0ed62f0660ce2f43003b2a745297f3b82dca486d7e4a9821441ad4ec92c202556515645d141fba31c998e17aa00bbe3d8c2106718e6839f94e88c975
DIST rails-6.0.4.3.tgz 18594602 BLAKE2B 99ee38f02ffece7972b34dc4bf8de6aece131fbdd1ac92c01272296e87b033d0a877a4fc724d3acece0442025ff9906a3e735ae75a8313135f2ffc55be988b38 SHA512 ae71145cc6e2a532271f6fe063347b261a7c6b1153f4978da5fd539b51b356baa555e731b759d9b49c342b2623b30ff9962396346df66d7e97aeca1fa806b333
DIST rails-6.1.4.1.tgz 11003728 BLAKE2B 8baa45968536ebe34f3bc4e4f25246bff68997a88c1019d1f7b7ba73785bc11901d7222ac04866b900c7dc35f9291ede78c0949abd979e797d07f3759179c05a SHA512 411d3fe21c7500e884edb86cc6728c4d3b7125d2e6ea913191437716f2be0d522252c55c25cb4c5221cc112b3ca5eeba690b0b0e59572fcc54ea42ba05ec4520
+DIST rails-6.1.4.3.tgz 11007190 BLAKE2B 085d500407f03d8c46335d91e3ebc5cd092c801de25f7e4fd5ac4ae6f03e54c5347e720386763307e183e2f0f48aaf84142092f47b62ab395082e4068e46f883 SHA512 f47a2e155fc80c287360b1a17a0f870208c523a28b77737648b4f260dc4fec6e9ccc91861b84862828fda48c214d39dcff32430ed5a02c8b9ee59ba6efb6151c
diff --git a/dev-ruby/actionmailbox/actionmailbox-6.1.4.3.ebuild b/dev-ruby/actionmailbox/actionmailbox-6.1.4.3.ebuild
new file mode 100644
index 000000000000..1450d0de17d9
--- /dev/null
+++ b/dev-ruby/actionmailbox/actionmailbox-6.1.4.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailbox.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app config db"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activejob-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/mail-2.7.1:*
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/mocha
+ dev-ruby/webmock
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|webrick\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|capybara\|webpacker\|bootsnap\|dalli\|connection_pool\|rexml\)/ s:^:#:" \
+ -e '/group :\(cable\|doc\|job\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
+ -i ../Gemfile || die
+ rm ../Gemfile.lock || die
+ sed -i -e '/byebug/ s:^:#:' test/test_helper.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}