summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-09-19 09:50:38 +0200
committerHans de Graaff <graaff@gentoo.org>2021-09-19 09:50:49 +0200
commitdd4b9a107cd1373123336738b94d71afd6433f8b (patch)
tree0c5fc91b9521de9333655ee0abad16ac329c3be5 /dev-ruby/actionmailbox
parentdev-ruby/actiontext: fix required test deps (diff)
downloadgentoo-dd4b9a107cd1373123336738b94d71afd6433f8b.tar.gz
gentoo-dd4b9a107cd1373123336738b94d71afd6433f8b.tar.bz2
gentoo-dd4b9a107cd1373123336738b94d71afd6433f8b.zip
dev-ruby/actionmailbox: fix test dependencies
Closes: https://bugs.gentoo.org/811813 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actionmailbox')
-rw-r--r--dev-ruby/actionmailbox/actionmailbox-6.1.4.1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-ruby/actionmailbox/actionmailbox-6.1.4.1.ebuild b/dev-ruby/actionmailbox/actionmailbox-6.1.4.1.ebuild
index a7b4314f4711..948cb48d3cd6 100644
--- a/dev-ruby/actionmailbox/actionmailbox-6.1.4.1.ebuild
+++ b/dev-ruby/actionmailbox/actionmailbox-6.1.4.1.ebuild
@@ -37,13 +37,14 @@ ruby_add_rdepend "
ruby_add_bdepend "test? (
dev-ruby/bundler
dev-ruby/mocha
+ dev-ruby/webmock
)"
all_ruby_prepare() {
# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
- sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|capybara\|webpacker\|bootsnap\|dalli\)/ s:^:#:" \
- -e '/group :\(doc\|job\|rubocop\|test\)/,/^end/ s:^:#:' \
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|webrick\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|capybara\|webpacker\|bootsnap\|dalli\|connection_pool\|rexml\)/ s:^:#:" \
+ -e '/group :\(cable\|doc\|job\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
-i ../Gemfile || die
rm ../Gemfile.lock || die
sed -i -e '/byebug/ s:^:#:' test/test_helper.rb || die