summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-08 11:52:10 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-08 11:54:08 +0200
commitbd830e8fe9f2c6d3a063b7176326e37b4b93b165 (patch)
tree77c599738715c9a3d0f53c374a3d20a361ec163c /dev-ruby/actionmailer/actionmailer-5.1.2.ebuild
parentdev-ruby/actionpack: add rails 5.1.2 (diff)
downloadgentoo-bd830e8fe9f2c6d3a063b7176326e37b4b93b165.tar.gz
gentoo-bd830e8fe9f2c6d3a063b7176326e37b4b93b165.tar.bz2
gentoo-bd830e8fe9f2c6d3a063b7176326e37b4b93b165.zip
dev-ruby/actionmailer: add rails 5.1.2
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/actionmailer/actionmailer-5.1.2.ebuild')
-rw-r--r--dev-ruby/actionmailer/actionmailer-5.1.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/actionmailer/actionmailer-5.1.2.ebuild b/dev-ruby/actionmailer/actionmailer-5.1.2.ebuild
new file mode 100644
index 000000000000..c6816e66ecd8
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-5.1.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~amd64-linux"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/actionview-${PV}
+ ~dev-ruby/activejob-${PV}
+ >=dev-ruby/mail-2.5.4:* =dev-ruby/mail-2*:*
+ dev-ruby/rails-dom-testing:2"
+
+ruby_add_bdepend "test? (
+ dev-ruby/mocha:0.14
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Avoid a test failing only on attachment ordering, since this is a
+ # security release.
+ sed -i -e '/adding inline attachments while rendering mail works/askip "gentoo: fails on ordering"' test/base_test.rb || die
+}