summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-03-22 07:18:33 +0100
committerHans de Graaff <graaff@gentoo.org>2020-03-22 07:30:22 +0100
commit7925b726e0537743b8d9807722b5a8cfb7ada0a5 (patch)
treeb967041439d3230e59d85f6c7910c1aab2d792ee /dev-ruby/actionpack/actionpack-5.2.4.2.ebuild
parentdev-ruby/actionview: add 5.2.4.2 (diff)
downloadgentoo-7925b726e0537743b8d9807722b5a8cfb7ada0a5.tar.gz
gentoo-7925b726e0537743b8d9807722b5a8cfb7ada0a5.tar.bz2
gentoo-7925b726e0537743b8d9807722b5a8cfb7ada0a5.zip
dev-ruby/actionpack: add 5.2.4.2
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actionpack/actionpack-5.2.4.2.ebuild')
-rw-r--r--dev-ruby/actionpack/actionpack-5.2.4.2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-ruby/actionpack/actionpack-5.2.4.2.ebuild b/dev-ruby/actionpack/actionpack-5.2.4.2.ebuild
new file mode 100644
index 000000000000..fe14eb07b740
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-5.2.4.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="Eases web-request routing, handling, and response"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionview-${PV}
+ >=dev-ruby/rack-2.0.8:2.0
+ >=dev-ruby/rack-test-0.6.3:*
+ >=dev-ruby/rails-html-sanitizer-1.0.2:1
+ dev-ruby/rails-dom-testing:2
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ dev-ruby/bundler
+ >=dev-ruby/capybara-2.15
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/rack-cache-1.2:1.2
+ www-servers/puma
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ sed -e '1i gem "activemodel", "~> 5.2.0"' \
+ -e '1i gem "actionview", "~> 5.2.0"' \
+ -e '1i gem "railties", "~> 5.2.0"' \
+ -i test/abstract_unit.rb || die
+}