summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-04-27 07:00:56 +0200
committerHans de Graaff <graaff@gentoo.org>2020-04-27 09:15:49 +0200
commit03eb2c72ae6374346299c78deb391d0ef72a6ae5 (patch)
treee3630076eaba7e1b3f5c8c7b578d4a203ec4272a /dev-ruby/actionpack/actionpack-6.0.2.2.ebuild
parentdev-lang/rust-bin: quote variable (diff)
downloadgentoo-03eb2c72ae6374346299c78deb391d0ef72a6ae5.tar.gz
gentoo-03eb2c72ae6374346299c78deb391d0ef72a6ae5.tar.bz2
gentoo-03eb2c72ae6374346299c78deb391d0ef72a6ae5.zip
dev-ruby/actionpack: add fix timezone tests
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actionpack/actionpack-6.0.2.2.ebuild')
-rw-r--r--dev-ruby/actionpack/actionpack-6.0.2.2.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-ruby/actionpack/actionpack-6.0.2.2.ebuild b/dev-ruby/actionpack/actionpack-6.0.2.2.ebuild
index f22c41d0d073..4de989d426cc 100644
--- a/dev-ruby/actionpack/actionpack-6.0.2.2.ebuild
+++ b/dev-ruby/actionpack/actionpack-6.0.2.2.ebuild
@@ -52,4 +52,7 @@ all_ruby_prepare() {
-e '/:job/,/end/ s:^:#:' \
-e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
rm ../Gemfile.lock || die
+
+ # Use different timezone notation, this changed at some point due to an external dependency changing.
+ sed -i -e 's/-0000/GMT/' test/dispatch/response_test.rb test/dispatch/cookies_test.rb test/dispatch/session/cookie_store_test.rb || die
}