summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-14 10:32:16 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-14 10:32:51 +0200
commitf3876beecef4107ea38f7d3d1d51d296a9b68a3b (patch)
tree3919f9b52dc1025fb8c0ed4676faab80e160b9dd /dev-ruby/actiontext
parentdev-ruby/activerecord: add 7.0.3 (diff)
downloadgentoo-f3876beecef4107ea38f7d3d1d51d296a9b68a3b.tar.gz
gentoo-f3876beecef4107ea38f7d3d1d51d296a9b68a3b.tar.bz2
gentoo-f3876beecef4107ea38f7d3d1d51d296a9b68a3b.zip
dev-ruby/actiontext: add 7.0.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actiontext')
-rw-r--r--dev-ruby/actiontext/Manifest1
-rw-r--r--dev-ruby/actiontext/actiontext-7.0.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-ruby/actiontext/Manifest b/dev-ruby/actiontext/Manifest
index 5a95531b1075..c09c30aa170e 100644
--- a/dev-ruby/actiontext/Manifest
+++ b/dev-ruby/actiontext/Manifest
@@ -9,3 +9,4 @@ DIST rails-6.1.6.tgz 10993299 BLAKE2B 98a80cbefc1aafba68a22b60d3df6b81ab1e8247a7
DIST rails-7.0.2.2.tgz 11034626 BLAKE2B 388a27b5434f1ae062cb7c3a68881a885dd659dbd9e86c4d36e0cb29c493f127fb9cbdf0f9ce7dea5a715ddbcd7a3bff5e2de3adb2e278c8bf63c2473d1e4b6d SHA512 e7863f1e072d266b8df1abb8abf6b141bad74ef77fe5dbcd66e7603e2ebf386520e4fd8f337edb5f5a6bd5607fbaa146823cbe6980fd7864e3934a7c9d382e3d
DIST rails-7.0.2.3.tgz 11037677 BLAKE2B b4d0ac3d2c56d262beca4f5ba1659a67526c01321dc00ef8392a11c6fbc7614e3c02cf02ffcbb5ed1911005c1be0c0741e225f45c5946fc9102629c5ba5d32ab SHA512 4dcbe65ce1bad803dd04be61918f1ca893529705a8336a0c09b0193eb453319fc42ed0e2dca6ff5cb56f0c2bc5ab03c9d9f479101904ad1a746980cd887798d4
DIST rails-7.0.2.4.tgz 11014591 BLAKE2B 4a678dddca134769a40d73a6652a6aa273456288c19ddbe7611ae40a14860abf77226ab351ead92647fb471751521377c51cafae40383198ff3d3477bc257b55 SHA512 948cf58dd6ac517fb4b1e63c3a1dbfcf2405fd224ea150cb92f5805939d3a458ad26e139b1c6069cc587c01f15694be14e119ee56769a611e6b6eaa0eae5a68c
+DIST rails-7.0.3.tgz 11021571 BLAKE2B 00385233279a773221ae8a1e75354d404d033206089323c53c0e81a134941151aab4578218438dd4193b2c00a0cd4ef1eb6a758502a51d403bddb11915ed9eb7 SHA512 366eaae24b0e147c9e33179c10c0a22f7c7671551222e329120749f04077bd344fabf55e90af041322787bf3063add927c7fd34758ae8764e00f8d8edba388ef
diff --git a/dev-ruby/actiontext/actiontext-7.0.3.ebuild b/dev-ruby/actiontext/actiontext-7.0.3.ebuild
new file mode 100644
index 000000000000..8c0fa471c2ba
--- /dev/null
+++ b/dev-ruby/actiontext/actiontext-7.0.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actiontext.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app db package.json"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Edit and display rich text in Rails applications"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/globalid-0.6.0
+ >=dev-ruby/nokogiri-1.8.5
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/mocha
+ dev-ruby/propshaft
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webpacker\|webrick\|webmock\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|bootsnap\|capybara\|dalli\|connection_pool\)/ s:^:#:" \
+ -e '/stimulus-rails/,/tailwindcss-rails/ s:^:#:' \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :\(cable\|doc\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
+ -i ../Gemfile || die
+ rm ../Gemfile.lock || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}