summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-11-30 08:01:06 +0100
committerHans de Graaff <graaff@gentoo.org>2018-11-30 08:05:53 +0100
commit6df98346b2ebe9b0a38d3a10b867b003a1150b47 (patch)
tree42cc719daef328a65064b3d8ce5da58b6f55973d /dev-ruby/activejob/activejob-5.1.6.1.ebuild
parentdev-ruby/actioncable: add 5.1.6.1 (diff)
downloadgentoo-6df98346b2ebe9b0a38d3a10b867b003a1150b47.tar.gz
gentoo-6df98346b2ebe9b0a38d3a10b867b003a1150b47.tar.bz2
gentoo-6df98346b2ebe9b0a38d3a10b867b003a1150b47.zip
dev-ruby/activejob: add 5.1.6.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/activejob/activejob-5.1.6.1.ebuild')
-rw-r--r--dev-ruby/activejob/activejob-5.1.6.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/activejob/activejob-5.1.6.1.ebuild b/dev-ruby/activejob/activejob-5.1.6.1.ebuild
new file mode 100644
index 000000000000..252f4c0af26a
--- /dev/null
+++ b/dev-ruby/activejob/activejob-5.1.6.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Job framework with pluggable queues"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/globalid-0.3.6
+"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.14.0:0.14
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/helper.rb || die "Unable to remove load paths"
+
+ # Remove all currently unpackaged queues.
+ sed -i -e 's/que queue_classic resque sidekiq sneakers sucker_punch backburner//' Rakefile || die
+}