summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-10 07:02:54 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-10 07:29:30 +0200
commit668e03e403e243feed66bc91e8b5630c4c956002 (patch)
treed31fc0aa303a8ddec6caf7a487b929232e0ec273 /dev-ruby/activejob/activejob-5.2.4.4.ebuild
parentdev-ruby/actioncable: add 5.2.4.4 (diff)
downloadgentoo-668e03e403e243feed66bc91e8b5630c4c956002.tar.gz
gentoo-668e03e403e243feed66bc91e8b5630c4c956002.tar.bz2
gentoo-668e03e403e243feed66bc91e8b5630c4c956002.zip
dev-ruby/activejob: add 5.2.4.4
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/activejob/activejob-5.2.4.4.ebuild')
-rw-r--r--dev-ruby/activejob/activejob-5.2.4.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/activejob/activejob-5.2.4.4.ebuild b/dev-ruby/activejob/activejob-5.2.4.4.ebuild
new file mode 100644
index 000000000000..7e36b898f263
--- /dev/null
+++ b/dev-ruby/activejob/activejob-5.2.4.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="Job framework with pluggable queues"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/globalid-0.3.6
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/helper.rb || die "Unable to remove load paths"
+
+ # Remove all currently unpackaged queues.
+ sed -i -e 's/que queue_classic resque sidekiq sneakers sucker_punch backburner//' \
+ -e 's/delayed_job//' Rakefile || die
+}