summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-05-18 20:39:31 +0200
committerHans de Graaff <graaff@gentoo.org>2020-05-18 20:45:09 +0200
commit345bf0ce5e63a200da3e7d5554a4a9c79bbc7f40 (patch)
treeb71b5ed5ed4b11752a799512cf7132e779d82ec7 /dev-ruby/activejob/activejob-6.0.3.1.ebuild
parentdev-ruby/actioncable: add 6.0.3.1 (diff)
downloadgentoo-345bf0ce5e63a200da3e7d5554a4a9c79bbc7f40.tar.gz
gentoo-345bf0ce5e63a200da3e7d5554a4a9c79bbc7f40.tar.bz2
gentoo-345bf0ce5e63a200da3e7d5554a4a9c79bbc7f40.zip
dev-ruby/activejob: add 6.0.3.1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/activejob/activejob-6.0.3.1.ebuild')
-rw-r--r--dev-ruby/activejob/activejob-6.0.3.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/activejob/activejob-6.0.3.1.ebuild b/dev-ruby/activejob/activejob-6.0.3.1.ebuild
new file mode 100644
index 000000000000..b6081286eb11
--- /dev/null
+++ b/dev-ruby/activejob/activejob-6.0.3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Job framework with pluggable queues"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/globalid-0.3.6
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/helper.rb || die "Unable to remove load paths"
+
+ # Remove all currently unpackaged queues.
+ sed -i -e 's/que queue_classic resque sidekiq sneakers sucker_punch backburner//' \
+ -e 's/delayed_job//' Rakefile || die
+ sed -i -e '/SneakersAdapter/ s:^:#:' test/cases/exceptions_test.rb || die
+}