summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-08-17 06:35:00 +0200
committerHans de Graaff <graaff@gentoo.org>2020-08-17 06:40:17 +0200
commit94b73f5ae7797987e3bf63898910d1c49998e2a4 (patch)
tree54511eb8a1bfc6f508d25e34121f6abd76c99cb8 /dev-ruby/activeldap/activeldap-6.0.3.ebuild
parentdev-libs/libgpg-error: Stabilize 1.38 arm, #737162 (diff)
downloadgentoo-94b73f5ae7797987e3bf63898910d1c49998e2a4.tar.gz
gentoo-94b73f5ae7797987e3bf63898910d1c49998e2a4.tar.bz2
gentoo-94b73f5ae7797987e3bf63898910d1c49998e2a4.zip
dev-ruby/activeldap: add 6.0.3
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/activeldap/activeldap-6.0.3.ebuild')
-rw-r--r--dev-ruby/activeldap/activeldap-6.0.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/activeldap/activeldap-6.0.3.ebuild b/dev-ruby/activeldap/activeldap-6.0.3.ebuild
new file mode 100644
index 000000000000..2c07111cb086
--- /dev/null
+++ b/dev-ruby/activeldap/activeldap-6.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="TODO doc/text/*"
+RUBY_FAKEGEM_EXTRAINSTALL="po"
+
+inherit ruby-fakegem
+
+MY_P="${P/ruby-/}"
+DESCRIPTION="ActiveLDAP provides an activerecord inspired object oriented interface to LDAP"
+HOMEPAGE="https://github.com/activeldap/activeldap"
+
+LICENSE="GPL-2"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Most tests require a live LDAP server to run.
+RESTRICT="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/activemodel-5.2.0:*
+ dev-ruby/builder
+ dev-ruby/locale
+ dev-ruby/ruby-gettext
+ dev-ruby/gettext_i18n_rails
+ || ( dev-ruby/ruby-net-ldap >=dev-ruby/ruby-ldap-0.8.2 )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc doc/text/*
+ dodoc -r examples
+}