summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-06-27 07:21:58 +0200
committerHans de Graaff <graaff@gentoo.org>2023-06-27 07:24:24 +0200
commitd99a88d9e6fc73b1d9a87ad3035b743125e78b12 (patch)
tree4acdf6442a171b9802ab0b4c58416481c828b659 /dev-ruby/activemodel/activemodel-7.0.5.1.ebuild
parentdev-ruby/activesupport: add 7.0.5.1 (diff)
downloadgentoo-d99a88d9e6fc73b1d9a87ad3035b743125e78b12.tar.gz
gentoo-d99a88d9e6fc73b1d9a87ad3035b743125e78b12.tar.bz2
gentoo-d99a88d9e6fc73b1d9a87ad3035b743125e78b12.zip
dev-ruby/activemodel: add 7.0.5.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/activemodel/activemodel-7.0.5.1.ebuild')
-rw-r--r--dev-ruby/activemodel/activemodel-7.0.5.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/activemodel/activemodel-7.0.5.1.ebuild b/dev-ruby/activemodel/activemodel-7.0.5.1.ebuild
new file mode 100644
index 000000000000..4557e34ae486
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-7.0.5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Toolkit for building modeling frameworks like Active Record and Active Resource"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}:*
+"
+
+ruby_add_bdepend "
+ test? (
+ ~dev-ruby/railties-${PV}
+ dev-ruby/test-unit:2
+ dev-ruby/mocha
+ >=dev-ruby/bcrypt-ruby-3.1.7
+ <dev-ruby/minitest-5.16:*
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}