summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-08-20 07:56:40 +0200
committerHans de Graaff <graaff@gentoo.org>2021-08-20 08:02:00 +0200
commit14942fd107fac8510c5304f47536442ddf935428 (patch)
treea475c7bb8b1f6fbe3f2bd5aa7b870db4f7da43d3 /dev-ruby/activesupport
parentdev-python/parso: sparc stable wrt bug #809113 (diff)
downloadgentoo-14942fd107fac8510c5304f47536442ddf935428.tar.gz
gentoo-14942fd107fac8510c5304f47536442ddf935428.tar.bz2
gentoo-14942fd107fac8510c5304f47536442ddf935428.zip
dev-ruby/activesupport: add 6.1.4.1
Closes: https://bugs.gentoo.org/770472 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-6.1.4.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 955a0f871619..c4787cee7548 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -3,4 +3,5 @@ DIST rails-6.0.3.7.tgz 18570545 BLAKE2B 6433705f18075e286d14d25dd87def61a3ac9c7a
DIST rails-6.0.4.1.tgz 18595307 BLAKE2B 9a950a45cd04c5fe0cbe57fd014a6997074dcbe8f95fcbb2f5d3b6372867ef8bb0931b909ca8eba623787419f5f45504cdcd477729ba3b3a052f5003229121cd SHA512 322cfa6d0ed62f0660ce2f43003b2a745297f3b82dca486d7e4a9821441ad4ec92c202556515645d141fba31c998e17aa00bbe3d8c2106718e6839f94e88c975
DIST rails-6.0.4.tgz 18594882 BLAKE2B e24ede90a572bc5ebd8244f45b987a62d50080af38e7e8b1689b9af88b66e194c0c3859e35ec2efbd306fc0c2f62a9d8aaa669fb73ddedd940c23aabc2719c2e SHA512 5a9a050ea44716cf72985643098a08716d191fe08d2cf4404fdf80709340c68d4ca083929c7118dad2532cc64a96c28e5dee3ac9541c10745d0f9d0583eda685
DIST rails-6.1.3.2.tgz 10992572 BLAKE2B ec4b7c33180ecc6b9dc9bd0270c9c03e48a774a7c0fc1d79638bd6b52a4c9831f59c5d8714e24c9611ac9e8ad03dddc664c2969da8be568eade76464c04d5697 SHA512 3b30facfe0555c3161b5fc50efb7dc1f3df0eeadbfa19f16df3ebdb4877d6fb9a978ae7a6713a502d79e6d8f1be20157bd5ef64919fdd558cad89492cc2d9672
+DIST rails-6.1.4.1.tgz 11003728 BLAKE2B 8baa45968536ebe34f3bc4e4f25246bff68997a88c1019d1f7b7ba73785bc11901d7222ac04866b900c7dc35f9291ede78c0949abd979e797d07f3759179c05a SHA512 411d3fe21c7500e884edb86cc6728c4d3b7125d2e6ea913191437716f2be0d522252c55c25cb4c5221cc112b3ca5eeba690b0b0e59572fcc54ea42ba05ec4520
DIST rails-6.1.4.tgz 11003156 BLAKE2B a0068d221da9c2b3be73f45b84ca1c1c926dfab5b759364d25428291624be31dd664faff32930ec59d5902682950895e6a5b40bcaf6106ad274622741b8f316c SHA512 e88781c690b00441fda0d50514b3ce1dde2ba4c5b93c775a6f77d50bd9aa736631c4d8b1ca6f5d0e270b8ebe902f7945823df7d0d7513881fa6b35c03bcf388f
diff --git a/dev-ruby/activesupport/activesupport-6.1.4.1.ebuild b/dev-ruby/activesupport/activesupport-6.1.4.1.ebuild
new file mode 100644
index 000000000000..76b3ac7c82f2
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-6.1.4.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ >=dev-ruby/i18n-1.6:1
+ dev-ruby/tzinfo:2
+ >=dev-ruby/minitest-5.1:5
+ >=dev-ruby/zeitwerk-2.3:2
+"
+
+# memcache-client, nokogiri, builder, and redis are not strictly needed,
+# but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.3:3
+ dev-ruby/rack
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|redis\|sqlite\|websocket-client-simple\|\libxml-ruby\|bootsnap\|blade\|aws-sdk\|webmock\|capybara\|sass-rails\|selenium-webdriver\)/ s:^:#:" \
+ -e '/group :\(doc\|rubocop\|job\|cable\|storage\|ujs\|test\) do/,/^end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"; gem "rack"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+# sed -i -e '1igem "tzinfo", "~> 1.1"' test/abstract_unit.rb || die
+
+ # Avoid test that depends on timezone
+ sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions.
+ rm -f test/evented_file_update_checker_test.rb || die
+
+ # Avoid test that generates filename that is too long
+ sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
+
+ # Avoid tests requiring a live redis running
+ rm -f test/cache/stores/redis_cache_store_test.rb || die
+ sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
+ sed -i -e '/test_redis_cache_store/askip "lacking keywords"' test/cache/cache_store_setting_test.rb || die
+}