summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-05-06 06:09:43 +0200
committerHans de Graaff <graaff@gentoo.org>2021-05-06 06:09:43 +0200
commit995e62366f9de4982aadd25bdf5aeb2e9bb7621c (patch)
treebdfca2b738b070759209b355cd62036f0897eb10 /dev-ruby/activesupport
parentapp-crypt/certbot-nginx: 1.15.0 bump (diff)
downloadgentoo-995e62366f9de4982aadd25bdf5aeb2e9bb7621c.tar.gz
gentoo-995e62366f9de4982aadd25bdf5aeb2e9bb7621c.tar.bz2
gentoo-995e62366f9de4982aadd25bdf5aeb2e9bb7621c.zip
dev-ruby/activesupport: add 6.1.3.2
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-6.1.3.2.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index e3a84c79b524..8c8354942c66 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -2,4 +2,5 @@ DIST rails-5.2.4.5.tgz 8826076 BLAKE2B 41a13708f72f0c281af7b6c97828d873b94319133
DIST rails-6.0.3.5.tgz 18566999 BLAKE2B b07d1d6c1e2ebaaf3c337350bb08fe339e324818543dcd7163fe3c7ff56f50c5556f369badeb4fd48afa6d95449e18e57fa1b05db6ce544d38ee2f58bd3aa513 SHA512 c9d6bf689aeb40fb728fb681b65c48ebd51de893060ddac37a1fdefbb0d420cee3a456f148d96d577c651c9d7b994efdb3319fa865cb012af8712052a20a0bf3
DIST rails-6.1.2.1.tgz 10990239 BLAKE2B ff1c9781eab32fda320cb2b9efc92e52ed155b659a43385781bfa422d03653879367bedc7ef4e3accb0a51b7962054eecd5202fd1e1a49ff7946c2f9388a69df SHA512 61e8bf0568c0b06a2c8f6c5e4ae6becc521646a5cdd3d6832c3b52998326a4bd437ad2bd284c010d445a3dc54bf519f7fbd2e9d4368c91b7d2a9abe46e3a276d
DIST rails-6.1.3.1.tgz 10991507 BLAKE2B 6798364c4d8c6339269950b5b583cbaa4c6d86b7880e7fa181bb6e52bb0d18b051eec233b2819af1668dcee8c4f40765fa9c46c6bb36329d0eda19f559a7472b SHA512 8c40d739b8300eec5d054bb0481133995875fa0bf854c1f5febceba7c0d156c9f249952687f0132bbc36ac59606013625b395faa301173ecdd247b4de0bc168b
+DIST rails-6.1.3.2.tgz 10992572 BLAKE2B ec4b7c33180ecc6b9dc9bd0270c9c03e48a774a7c0fc1d79638bd6b52a4c9831f59c5d8714e24c9611ac9e8ad03dddc664c2969da8be568eade76464c04d5697 SHA512 3b30facfe0555c3161b5fc50efb7dc1f3df0eeadbfa19f16df3ebdb4877d6fb9a978ae7a6713a502d79e6d8f1be20157bd5ef64919fdd558cad89492cc2d9672
DIST rails-6.1.3.tgz 10991190 BLAKE2B d7a01ad39d4caaee1eaeed9909255fe16c3bd224c61408aca8e319e21ea36566a5be4bbaff37d4d19ee88ec2914e08f85e4e71c970ba39ade8b86f8ba4603b25 SHA512 ec6e871e3226c3efa5dc7f59cbd1819b45ab0d1a21b39b8c2d76022fff761fb268f79c7b560b987af245d9e305ecc4517379de3769d468b5a548005f8533044a
diff --git a/dev-ruby/activesupport/activesupport-6.1.3.2.ebuild b/dev-ruby/activesupport/activesupport-6.1.3.2.ebuild
new file mode 100644
index 000000000000..077b419f7711
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-6.1.3.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ >=dev-ruby/i18n-1.6:1
+ dev-ruby/tzinfo:2
+ >=dev-ruby/minitest-5.1:5
+ >=dev-ruby/zeitwerk-2.3:2
+"
+
+# memcache-client, nokogiri, builder, and redis are not strictly needed,
+# but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.3:3
+ dev-ruby/rack
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|redis\|sqlite\|websocket-client-simple\|\libxml-ruby\|bootsnap\|blade\|aws-sdk\|webmock\|sass-rails\|selenium-webdriver\)/ s:^:#:" \
+ -e '/group :\(doc\|rubocop\|job\|cable\|storage\|ujs\|test\) do/,/^end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"; gem "rack"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+# sed -i -e '1igem "tzinfo", "~> 1.1"' test/abstract_unit.rb || die
+
+ # Avoid test that depends on timezone
+ sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions.
+ rm -f test/evented_file_update_checker_test.rb || die
+
+ # Avoid test that generates filename that is too long
+ sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
+
+ # Avoid tests requiring a live redis running
+ rm -f test/cache/stores/redis_cache_store_test.rb || die
+ sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
+ sed -i -e '/test_redis_cache_store/askip "lacking keywords"' test/cache/cache_store_setting_test.rb || die
+}