summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-07-04 10:23:23 +0200
committerHans de Graaff <graaff@gentoo.org>2020-07-04 10:24:26 +0200
commitaa0291b362fa865fc2143a6608a0e84687a1554d (patch)
tree0b63223148ba30d170e17bf995ffc0bc32fb8ef4 /dev-ruby/activesupport
parentdev-ruby/activemodel: cleanup (diff)
downloadgentoo-aa0291b362fa865fc2143a6608a0e84687a1554d.tar.gz
gentoo-aa0291b362fa865fc2143a6608a0e84687a1554d.tar.bz2
gentoo-aa0291b362fa865fc2143a6608a0e84687a1554d.zip
dev-ruby/activesupport: cleanup
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-5.2.4.2.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 0055cbcdc29d..f43a996c9c77 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -1,4 +1,3 @@
-DIST rails-5.2.4.2.tgz 8823143 BLAKE2B 273bee6ccc2354bcfd8d24b320fe69c24f643c196eba053c727d30b13d4178069068c430a0a4112ae28c3e4b5a5dde0b66a7c46c7c28054f2b7a678427f478af SHA512 21561407a0b606dbd2fb6ad12ef910c0bdf3d5162db7e55f4f41f698280ba73664b0b5594930d4cebcb42a66e2e5e22de3523789818eb424443e8c5b2316b8fc
DIST rails-5.2.4.3.tgz 8824955 BLAKE2B 7db1bdda581e345713b796152c68e13911076c0af752aa91016a559fb380ee33b5f1822576120940995968efa6351165af0e21f97ff2e201bc8250f7e3178089 SHA512 b01b454f38593b50788cecef4f2b25938b0e176d24476bf0a8145b581c7327e0d8572a62fab4256372b51d75a9463431bbd98470a31298a6ff4d5f81f7ff92ce
DIST rails-6.0.2.2.tgz 18556125 BLAKE2B f4ed5cc6cbbfa84fb687aba5a6c8f2f6ab68febb41147c40ed8dbc6253c128adbac6503e65e89fe672f50270716d197d8c05b4e1e286aafd76581fc167e6c5da SHA512 c1aab2d6c72948c75a047aec9d9f651f0c1bae78bb17e2fa0cb393113ee1e59980dc093e6f3fd3b2f3839c9b3bb4afcd0b0badfd9574b35b932275a9d9800689
DIST rails-6.0.3.1.tgz 18567937 BLAKE2B fe6b58c2cb389f766d356f983787ddd602ee835e90cdbe26c25586c1304aa8c80d4ace2e0956326c0dd428dcd51a624d68d64667c2294c326779498a809ea6c9 SHA512 fcdaff0b0e4877a53f89b2b69c9271213297db8df8abccd071da5f2b2d3e3e6855914e1059596903f761b9a3891b31c2fdf10e887183f4433b260f84c4ebccdf
diff --git a/dev-ruby/activesupport/activesupport-5.2.4.2.ebuild b/dev-ruby/activesupport/activesupport-5.2.4.2.ebuild
deleted file mode 100644
index d3a60061e699..000000000000
--- a/dev-ruby/activesupport/activesupport-5.2.4.2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eapi7-ver
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- >=dev-ruby/concurrent-ruby-1.0.2:1
- dev-ruby/i18n:1
- >=dev-ruby/tzinfo-1.1:1
- >=dev-ruby/minitest-5.1:5"
-
-# memcache-client, nokogiri, and builder are not strictly
-# needed, but there are tests using this code.
-ruby_add_bdepend "test? (
- >=dev-ruby/dalli-2.2.1
- >=dev-ruby/nokogiri-1.4.5
- >=dev-ruby/builder-3.1.0
- >=dev-ruby/listen-3.0.5:3
- dev-ruby/rack
- dev-ruby/mocha
- )"
-
-all_ruby_prepare() {
- # Set the secure permissions that tests expect.
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
-
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|redis\|sqlite\)/ s:^:#:" \
- -e '/:job/,/end/ s:^:#:' \
- -e '/group :doc/,/^end/ s:^:#:' \
- -e 's/gemspec/gemspec path: "activesupport"/' \
- -e '5igem "builder"; gem "rack"' ../Gemfile || die
- rm ../Gemfile.lock || die
- sed -i -e '1igem "tzinfo", "~> 1.1"' test/abstract_unit.rb || die
-
- # Avoid test that depends on timezone
- sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
-
- # Avoid tests that seem to trigger race conditions.
- rm -f test/evented_file_update_checker_test.rb || die
-
- # Avoid test that generates filename that is too long
- sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
-
- # Avoid tests requiring a live redis running
- rm -f test/cache/stores/redis_cache_store_test.rb || die
- sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
-}