summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-08-20 08:48:23 +0200
committerHans de Graaff <graaff@gentoo.org>2022-08-20 08:48:23 +0200
commit2ea6ed0a264d2df702e7d4ad497026546c725b00 (patch)
treecef78663ee7dff506aaaf99301cdfdce4cbfcdad /dev-ruby/addressable
parentsys-devel/mold: fix build with gcc-12 (diff)
downloadgentoo-2ea6ed0a264d2df702e7d4ad497026546c725b00.tar.gz
gentoo-2ea6ed0a264d2df702e7d4ad497026546c725b00.tar.bz2
gentoo-2ea6ed0a264d2df702e7d4ad497026546c725b00.zip
dev-ruby/addressable: add 2.8.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/addressable')
-rw-r--r--dev-ruby/addressable/Manifest1
-rw-r--r--dev-ruby/addressable/addressable-2.8.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/addressable/Manifest b/dev-ruby/addressable/Manifest
index d73e546c52ab..32b000f72afe 100644
--- a/dev-ruby/addressable/Manifest
+++ b/dev-ruby/addressable/Manifest
@@ -1 +1,2 @@
DIST addressable-2.8.0.gem 105984 BLAKE2B 82f053c9ad052ce1ed1b6927674bd5bcda86a3f70d46b63bfc1185d51b402996fd446647d705418791c5443a1767b4ecd0b891f26de63fbe737c62f7586bd57c SHA512 c684f17940f717c2a65f9716ab9b3659948d6d51a60c38a7295fcf6fdc1c5785d2d315d2de7dab9f66a6c31f62247177d78d5d6eb556f5bb49926d4f00f8e4c8
+DIST addressable-2.8.1.gem 105984 BLAKE2B 9ba6fffe2af965be57ef7b2f86c5c86c672e0037c41996d78a3b8f31a9b5a5818e06d7e119733cff3d5469bc985186fac6fa978740f107876a975b5ac662171f SHA512 ae0b7cb5fdc0b5b8717637e9589ab9167aa3924253f4c9102134b1e5aee07c7f5e3e92e2e32ca872b4a72a3a70c8086c7073cbbddf7cbb6e1948ed97de2c9108
diff --git a/dev-ruby/addressable/addressable-2.8.1.ebuild b/dev-ruby/addressable/addressable-2.8.1.ebuild
new file mode 100644
index 000000000000..4a80cd514c1b
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
+HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend "|| ( dev-ruby/public_suffix:5 dev-ruby/public_suffix:4 dev-ruby/public_suffix:3 )"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm -f tasks/rspec.rake || die
+ sed -i -e '/bundler/ s:^:#:' \
+ -e '/^begin/,/^end/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ # Remove specs requiring network connectivity
+ rm -f spec/addressable/net_http_compat_spec.rb || die
+
+ # Remove spec that tests against an unreleased github fork
+ rm -f spec/addressable/rack_mount_compat_spec.rb || die
+}