summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-02-06 07:49:18 +0100
committerHans de Graaff <graaff@gentoo.org>2021-02-06 07:49:18 +0100
commit74642e3aa888342ada4fdb24dc568b9dea37f21f (patch)
tree50b0c78aedec7cfe8cbaf5380539f4f6a5a79565 /dev-ruby/afm/afm-0.2.2-r1.ebuild
parentdev-ruby/nio4r: add 2.5.5 (diff)
downloadgentoo-74642e3aa888342ada4fdb24dc568b9dea37f21f.tar.gz
gentoo-74642e3aa888342ada4fdb24dc568b9dea37f21f.tar.bz2
gentoo-74642e3aa888342ada4fdb24dc568b9dea37f21f.zip
dev-ruby/afm: EAPI=7; add ruby30
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/afm/afm-0.2.2-r1.ebuild')
-rw-r--r--dev-ruby/afm/afm-0.2.2-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/afm/afm-0.2.2-r1.ebuild b/dev-ruby/afm/afm-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..51fbde2f60b2
--- /dev/null
+++ b/dev-ruby/afm/afm-0.2.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A very simple library to read Adobe Font Metrics files"
+HOMEPAGE="https://github.com/halfbyte/afm"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/s/^/#/" Rakefile test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/test_afm.rb || die
+}