summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-16 08:18:12 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-16 08:45:31 +0200
commit9e2781a16b6eaf55c3c91eee4084023a7c5298d7 (patch)
tree03df0bfb3280397bb855b1ce35119a0b8fd78505 /dev-ruby/amatch/amatch-0.4.0.ebuild
parentdev-ruby/async_sinatra: add 1.3.0 (diff)
downloadgentoo-9e2781a16b6eaf55c3c91eee4084023a7c5298d7.tar.gz
gentoo-9e2781a16b6eaf55c3c91eee4084023a7c5298d7.tar.bz2
gentoo-9e2781a16b6eaf55c3c91eee4084023a7c5298d7.zip
dev-ruby/amatch: add 0.4.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/amatch/amatch-0.4.0.ebuild')
-rw-r--r--dev-ruby/amatch/amatch-0.4.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/amatch/amatch-0.4.0.ebuild b/dev-ruby/amatch/amatch-0.4.0.ebuild
new file mode 100644
index 000000000000..30a275a074dc
--- /dev/null
+++ b/dev-ruby/amatch/amatch-0.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Approximate Matching Extension for Ruby"
+HOMEPAGE="https://flori.github.com/amatch/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/tins-1*"
+
+all_ruby_prepare() {
+ # mize is listed as a dependency but not actually used
+ sed -i -e '/mize/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext V=1
+ cp ext/amatch_ext$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb-2 tests/* || die
+}