summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-01-28 07:36:22 +0100
committerHans de Graaff <graaff@gentoo.org>2017-01-28 07:36:22 +0100
commitf9f7b06c2ab2266784502ef1cb8c40cba5a92c6c (patch)
treece9d302d2802b84763b95a1650f68550c969d946 /dev-ruby/amq-protocol/amq-protocol-2.1.0.ebuild
parentx11-libs/libxkbfile: Add multilib support. (diff)
downloadgentoo-f9f7b06c2ab2266784502ef1cb8c40cba5a92c6c.tar.gz
gentoo-f9f7b06c2ab2266784502ef1cb8c40cba5a92c6c.tar.bz2
gentoo-f9f7b06c2ab2266784502ef1cb8c40cba5a92c6c.zip
dev-ruby/amq-protocol: add 2.1.0
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-ruby/amq-protocol/amq-protocol-2.1.0.ebuild')
-rw-r--r--dev-ruby/amq-protocol/amq-protocol-2.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/amq-protocol/amq-protocol-2.1.0.ebuild b/dev-ruby/amq-protocol/amq-protocol-2.1.0.ebuild
new file mode 100644
index 000000000000..b204c0505b13
--- /dev/null
+++ b/dev-ruby/amq-protocol/amq-protocol-2.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An AMQP 0.9.1 serialization library for Ruby"
+HOMEPAGE="https://github.com/ruby-amqp/amq-protocol"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/bundler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+}