summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-13 08:24:50 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-13 08:24:50 +0100
commit675b763e45919ba917e5eb617f99f9d0f5dbe461 (patch)
tree8e875ee05ac3deffba0d9a3c0ff55510834bf54d /dev-ruby/amq-protocol/amq-protocol-2.3.0.ebuild
parentsys-fs/udev: add m68k/s390/sh love to >=234-r1 (diff)
downloadgentoo-675b763e45919ba917e5eb617f99f9d0f5dbe461.tar.gz
gentoo-675b763e45919ba917e5eb617f99f9d0f5dbe461.tar.bz2
gentoo-675b763e45919ba917e5eb617f99f9d0f5dbe461.zip
dev-ruby/amq-protocol: add 2.3.0
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/amq-protocol/amq-protocol-2.3.0.ebuild')
-rw-r--r--dev-ruby/amq-protocol/amq-protocol-2.3.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/amq-protocol/amq-protocol-2.3.0.ebuild b/dev-ruby/amq-protocol/amq-protocol-2.3.0.ebuild
new file mode 100644
index 000000000000..65ddb930a2ff
--- /dev/null
+++ b/dev-ruby/amq-protocol/amq-protocol-2.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An AMQP 0.9.1 serialization library for Ruby"
+HOMEPAGE="https://github.com/ruby-amqp/amq-protocol"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ sed -i -e '/\(simplecov\|effin_utf8\|byebug\)/ s:^:#:' Gemfile || die
+ sed -i -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+}