summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-04-08 08:03:18 +0200
committerHans de Graaff <graaff@gentoo.org>2020-04-08 08:18:06 +0200
commit569b37efb0a6f183942942e05ae2604dc15f48aa (patch)
treeb709f7dd8109e2e6902a6df3cde298bc886af45c /dev-ruby/amq-protocol/amq-protocol-2.3.1.ebuild
parentdev-ruby/sync: sort keywords (diff)
downloadgentoo-569b37efb0a6f183942942e05ae2604dc15f48aa.tar.gz
gentoo-569b37efb0a6f183942942e05ae2604dc15f48aa.tar.bz2
gentoo-569b37efb0a6f183942942e05ae2604dc15f48aa.zip
dev-ruby/amq-protocol: add 2.3.1
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/amq-protocol/amq-protocol-2.3.1.ebuild')
-rw-r--r--dev-ruby/amq-protocol/amq-protocol-2.3.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/amq-protocol/amq-protocol-2.3.1.ebuild b/dev-ruby/amq-protocol/amq-protocol-2.3.1.ebuild
new file mode 100644
index 000000000000..a08d07b449c5
--- /dev/null
+++ b/dev-ruby/amq-protocol/amq-protocol-2.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An AMQP 0.9.1 serialization library for Ruby"
+HOMEPAGE="https://github.com/ruby-amqp/amq-protocol"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ sed -i -e '/\(simplecov\|effin_utf8\|byebug\)/ s:^:#:' Gemfile || die
+ sed -i -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+}