summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-07-11 07:14:55 +0200
committerHans de Graaff <graaff@gentoo.org>2020-07-11 07:15:14 +0200
commitd1b5d1da8107503b977bdca6639efa46ea2a56df (patch)
treec8c25b9f728649dc6e0f1022ba880626426d77d1 /dev-ruby/amq-protocol/amq-protocol-2.3.2.ebuild
parentdev-ruby/websocket-driver: add 0.7.3 (diff)
downloadgentoo-d1b5d1da8107503b977bdca6639efa46ea2a56df.tar.gz
gentoo-d1b5d1da8107503b977bdca6639efa46ea2a56df.tar.bz2
gentoo-d1b5d1da8107503b977bdca6639efa46ea2a56df.zip
dev-ruby/amq-protocol: add 2.3.2
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/amq-protocol/amq-protocol-2.3.2.ebuild')
-rw-r--r--dev-ruby/amq-protocol/amq-protocol-2.3.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/amq-protocol/amq-protocol-2.3.2.ebuild b/dev-ruby/amq-protocol/amq-protocol-2.3.2.ebuild
new file mode 100644
index 000000000000..b9e86769dc8c
--- /dev/null
+++ b/dev-ruby/amq-protocol/amq-protocol-2.3.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An AMQP 0.9.1 serialization library for Ruby"
+HOMEPAGE="https://github.com/ruby-amqp/amq-protocol"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ sed -i -e '/\(simplecov\|effin_utf8\|byebug\)/ s:^:#:' Gemfile || die
+ sed -i -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+}