summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-08 11:21:35 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-08 11:21:35 +0200
commiteb35ab144fa1c951960bb157603f41b9be733d82 (patch)
tree6aa0a803a9aef9d216e24838ade6a3af8a42bdcf /dev-ruby/amq-protocol
parentprofiles/package.mask: mask dev-ruby/annoy for removal (diff)
downloadgentoo-eb35ab144fa1c951960bb157603f41b9be733d82.tar.gz
gentoo-eb35ab144fa1c951960bb157603f41b9be733d82.tar.bz2
gentoo-eb35ab144fa1c951960bb157603f41b9be733d82.zip
dev-ruby/amq-protocol: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/amq-protocol')
-rw-r--r--dev-ruby/amq-protocol/amq-protocol-2.3.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/amq-protocol/amq-protocol-2.3.2-r1.ebuild b/dev-ruby/amq-protocol/amq-protocol-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..1d10251ee8ba
--- /dev/null
+++ b/dev-ruby/amq-protocol/amq-protocol-2.3.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An AMQP 0.9.1 serialization library for Ruby"
+HOMEPAGE="https://github.com/ruby-amqp/amq-protocol"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ sed -i -e '/\(simplecov\|effin_utf8\|byebug\)/ s:^:#:' Gemfile || die
+ sed -i -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid spec where host is either nil or "" depending on ruby version
+ sed -i -e '/falls back to default nil host/ s/it/xit/' spec/amq/uri_parsing_spec.rb || die
+}