summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-02-04 14:21:44 +0100
committerHans de Graaff <graaff@gentoo.org>2017-02-04 14:22:06 +0100
commitee2e90cbf0254b6e4f76d0e9e8e5060e95a74f3a (patch)
tree1e88761c0fb81f33fa77a6dfff678adc7f6219ff /dev-ruby/amqp/amqp-1.7.0.ebuild
parentdev-perl/Inline-C: Mark ~hppa (bug #576058). (diff)
downloadgentoo-ee2e90cbf0254b6e4f76d0e9e8e5060e95a74f3a.tar.gz
gentoo-ee2e90cbf0254b6e4f76d0e9e8e5060e95a74f3a.tar.bz2
gentoo-ee2e90cbf0254b6e4f76d0e9e8e5060e95a74f3a.zip
dev-ruby/amqp: add 1.7.0
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-ruby/amqp/amqp-1.7.0.ebuild')
-rw-r--r--dev-ruby/amqp/amqp-1.7.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/amqp/amqp-1.7.0.ebuild b/dev-ruby/amqp/amqp-1.7.0.ebuild
new file mode 100644
index 000000000000..6998606f6562
--- /dev/null
+++ b/dev-ruby/amqp/amqp-1.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit versionator ruby-fakegem
+
+DESCRIPTION="AMQP client implementation in Ruby/EventMachine"
+HOMEPAGE="http://rubyamqp.info/"
+
+LICENSE="Ruby"
+SLOT="1.4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/multi_json dev-ruby/evented-spec )"
+ruby_add_rdepend ">=dev-ruby/eventmachine-0.12.4
+ >=dev-ruby/amq-protocol-2.0.1:2"
+
+all_ruby_prepare() {
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+
+ # Many specs require a live rabbit server, but only root can start
+ # an instance. Skip these specs for now.
+ rm -rf spec/integration spec/unit/amqp/connection_spec.rb || die
+}
+
+all_ruby_install() {
+ dodoc -r docs examples
+}