summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-09 09:26:38 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-09 09:27:49 +0200
commit32669da140788b23ba02cebbe6b8b6344174023e (patch)
treea297bef67de6be259d33eb2a52512f26ed948b49 /dev-ruby/amqp
parentdev-ruby/amq-client: EAPI 8; add ruby27 (diff)
downloadgentoo-32669da140788b23ba02cebbe6b8b6344174023e.tar.gz
gentoo-32669da140788b23ba02cebbe6b8b6344174023e.tar.bz2
gentoo-32669da140788b23ba02cebbe6b8b6344174023e.zip
dev-ruby/amqp: EAPI 8; add ruby27
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/amqp')
-rw-r--r--dev-ruby/amqp/amqp-1.8.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/amqp/amqp-1.8.0-r1.ebuild b/dev-ruby/amqp/amqp-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..8dd9260cbc0a
--- /dev/null
+++ b/dev-ruby/amqp/amqp-1.8.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="AMQP client implementation in Ruby/EventMachine"
+HOMEPAGE="http://rubyamqp.info/"
+
+LICENSE="Ruby"
+SLOT="1.4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/multi_json dev-ruby/evented-spec )"
+ruby_add_rdepend ">=dev-ruby/eventmachine-0.12.4
+ >=dev-ruby/amq-protocol-2.2.0:2"
+
+all_ruby_prepare() {
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+
+ # Many specs require a live rabbit server, but only root can start
+ # an instance. Skip these specs for now.
+ rm -rf spec/integration spec/unit/amqp/connection_spec.rb || die
+}
+
+all_ruby_install() {
+ dodoc -r docs examples
+}