summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-10-10 07:16:03 +0200
committerHans de Graaff <graaff@gentoo.org>2016-10-10 07:16:03 +0200
commit03b64b41311ded684b60f043e0328be03d1306e2 (patch)
treef2d91c1ab46c9325e1d3404a66fef10469f1f195 /dev-ruby/arel/arel-7.1.4.ebuild
parentmedia-libs/virglrenderer: version bump to 0.5.0, bug #592056 (diff)
downloadgentoo-03b64b41311ded684b60f043e0328be03d1306e2.tar.gz
gentoo-03b64b41311ded684b60f043e0328be03d1306e2.tar.bz2
gentoo-03b64b41311ded684b60f043e0328be03d1306e2.zip
dev-ruby/arel: add 7.1.4
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/arel/arel-7.1.4.ebuild')
-rw-r--r--dev-ruby/arel/arel-7.1.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/arel/arel-7.1.4.ebuild b/dev-ruby/arel/arel-7.1.4.ebuild
new file mode 100644
index 000000000000..e2bf91e09d0d
--- /dev/null
+++ b/dev-ruby/arel/arel-7.1.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.md"
+
+RUBY_FAKEGEM_GEMSPEC="arel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Arel is a Relational Algebra for Ruby"
+HOMEPAGE="https://github.com/rails/arel"
+SRC_URI="https://github.com/rails/arel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1).0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ >=dev-ruby/minitest-5.4:5
+ )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" \
+ -e '/specname/,$ s:^:#:' Rakefile || die
+}