summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-01-17 21:51:37 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-01-17 21:51:53 +0100
commit6c92677742f34cd64d7f1f335256340bdbfbd98a (patch)
treeb8e4612b4cc50938ce5f185fadf2d28434b6faae /dev-ruby/asciidoctor
parentdev-perl/Apache-Reload: Remove old (diff)
downloadgentoo-6c92677742f34cd64d7f1f335256340bdbfbd98a.tar.gz
gentoo-6c92677742f34cd64d7f1f335256340bdbfbd98a.tar.bz2
gentoo-6c92677742f34cd64d7f1f335256340bdbfbd98a.zip
dev-ruby/asciidoctor: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/asciidoctor')
-rw-r--r--dev-ruby/asciidoctor/Manifest1
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-1.5.4.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor/Manifest b/dev-ruby/asciidoctor/Manifest
index ac840966b569..b3a9124d8278 100644
--- a/dev-ruby/asciidoctor/Manifest
+++ b/dev-ruby/asciidoctor/Manifest
@@ -1,2 +1,3 @@
DIST asciidoctor-1.5.2.tar.gz 494239 SHA256 f10242d7ea5e8c3b6279c9535e67d58fb0b8ffe2c5625e7b211af3dd683dd368 SHA512 5d50134d4bed58bb5dc610929c30b1272c8d75e9748f6587a4e00cd8d76b4f86e8edd17b04a8579d984e9ce3864c3d96a81bc526988a6c6d71e418923c94d67a WHIRLPOOL 67cf1cdd71dd4819c2d829d729057ec0b7b6ac107a5754333eb257a80545c4229870a1ae83b14172bd52e5e8b145bc1f56db6bca6af341d6ee7ca6b63267e7c8
DIST asciidoctor-1.5.3.tar.gz 509233 SHA256 b6aa27203bf9fc8ca55d0c0468f8f3e70ae1b3aa60f1bb50dd6aa53497275841 SHA512 17e5c930b2d2d1727b5b5f2100f6b625edf3af73e98aadf84135bdf01bbbef8587b310fe513508ae575ee6b8a08d573ac512fbfc3d6e9ea9e144048786865c35 WHIRLPOOL 9333bee73633e18b9c334d6f622df07e8d07c1a491852b710b2edc31c892ebbc00e2d915a9234253f7a13611988f8d53e3a791a73e4ca6cbd82e90444dce9fe1
+DIST asciidoctor-1.5.4.tar.gz 520793 SHA256 2963fdf5ce12962e3a514d7d83426897184c947de5df89300ee524970dc2f3bc SHA512 c3a6405a6c39d1aa70e4d10ce42a6f6e01f3b7ddd8f695e8043fce9116ac91ad1f1f881a449ee8a61172213720dae1285f9c4de03a5cec908de906ed5b14e626 WHIRLPOOL bb06147e6c77fc5d0133b0b747103ec362cc724624087cb84756b2a193540e6b164aed1c8a20a1578298be135e7b65938ae07a902409ba778c25792bd6350ec9
diff --git a/dev-ruby/asciidoctor/asciidoctor-1.5.4.ebuild b/dev-ruby/asciidoctor/asciidoctor-1.5.4.ebuild
new file mode 100644
index 000000000000..a1aa82a593b8
--- /dev/null
+++ b/dev-ruby/asciidoctor/asciidoctor-1.5.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test features"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for converting AsciiDoc into HTML 5, DocBook 4.5 and other formats"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec-expectations:*
+ dev-ruby/asciimath
+ dev-ruby/coderay
+ dev-ruby/erubis
+ dev-ruby/haml
+ dev-ruby/nokogiri
+ dev-ruby/slim
+ dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/asciidoctor.1
+}