summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-08-23 08:17:11 +0200
committerHans de Graaff <graaff@gentoo.org>2020-08-23 08:24:25 +0200
commite8d7e6d17cf2a2555a1f1bf86eba852d69acce48 (patch)
tree2c56864b23060ec2b21a1c65634608bd70d4a894 /dev-ruby/astrolabe/astrolabe-1.3.1-r1.ebuild
parentdev-ruby/base32: add ruby27 (diff)
downloadgentoo-e8d7e6d17cf2a2555a1f1bf86eba852d69acce48.tar.gz
gentoo-e8d7e6d17cf2a2555a1f1bf86eba852d69acce48.tar.bz2
gentoo-e8d7e6d17cf2a2555a1f1bf86eba852d69acce48.zip
dev-ruby/astrolabe: add ruby27
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/astrolabe/astrolabe-1.3.1-r1.ebuild')
-rw-r--r--dev-ruby/astrolabe/astrolabe-1.3.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/astrolabe/astrolabe-1.3.1-r1.ebuild b/dev-ruby/astrolabe/astrolabe-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..09912a68a210
--- /dev/null
+++ b/dev-ruby/astrolabe/astrolabe-1.3.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An object-oriented AST extension for Parser"
+HOMEPAGE="https://github.com/yujinakayama/astrolabe"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/parser-2.2.0_pre3"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ # Fix Specs until RSpec3 is available
+ sed -i -e "/mocks.verify_partial_doubles/ s/^/#/" spec/spec_helper.rb || die
+ sed -i -e "s/is_expected.to/should/" spec/astrolabe/node_spec.rb || die
+}