summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-01-15 06:33:01 +0100
committerHans de Graaff <graaff@gentoo.org>2020-01-15 06:44:03 +0100
commite836f98abbacd2ef076d0d57fa2395ab50187e61 (patch)
tree27ad7a3ade1a331e9bb03ae5456bf8e7010b4ec5 /dev-ruby/autoprefixer-rails/autoprefixer-rails-9.7.4.ebuild
parentdev-ruby/autoprefixer-rails: cleanup (diff)
downloadgentoo-e836f98abbacd2ef076d0d57fa2395ab50187e61.tar.gz
gentoo-e836f98abbacd2ef076d0d57fa2395ab50187e61.tar.bz2
gentoo-e836f98abbacd2ef076d0d57fa2395ab50187e61.zip
dev-ruby/autoprefixer-rails: add 9.7.4
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/autoprefixer-rails/autoprefixer-rails-9.7.4.ebuild')
-rw-r--r--dev-ruby/autoprefixer-rails/autoprefixer-rails-9.7.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/autoprefixer-rails/autoprefixer-rails-9.7.4.ebuild b/dev-ruby/autoprefixer-rails/autoprefixer-rails-9.7.4.ebuild
new file mode 100644
index 000000000000..2abda327ffb8
--- /dev/null
+++ b/dev-ruby/autoprefixer-rails/autoprefixer-rails-9.7.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add vendor prefixes to CSS rules using values from the Can I Use website"
+HOMEPAGE="https://github.com/ai/autoprefixer-rails"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/execjs:*"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rails-5.0.0
+ dev-ruby/rake
+ dev-ruby/rspec-rails
+)"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" -e "/BUNDLE/d" spec/app/config/boot.rb || die
+ sed -i -e "/Bundler/,+3d" \
+ -e '/config.sass/ s:^:#:' spec/app/config/application.rb || die
+ sed -i -e '/standard/ s:^:#:' autoprefixer-rails.gemspec || die
+ rm -f spec/rails_spec.rb || die
+}