summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-02-18 08:09:07 +0100
committerHans de Graaff <graaff@gentoo.org>2017-02-18 08:11:33 +0100
commit5a043a6c5419cc4219071b0d35f661966a0eb7d4 (patch)
tree5cf689b3d62fe5dc3a27a458f08b57871ea9b46f /dev-ruby/autoprefixer-rails
parentsys-libs/libcap-ng: Removed old. (diff)
downloadgentoo-5a043a6c5419cc4219071b0d35f661966a0eb7d4.tar.gz
gentoo-5a043a6c5419cc4219071b0d35f661966a0eb7d4.tar.bz2
gentoo-5a043a6c5419cc4219071b0d35f661966a0eb7d4.zip
dev-ruby/autoprefixer-rails: initial import of 6.7.3
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-ruby/autoprefixer-rails')
-rw-r--r--dev-ruby/autoprefixer-rails/Manifest1
-rw-r--r--dev-ruby/autoprefixer-rails/autoprefixer-rails-6.7.3.ebuild32
-rw-r--r--dev-ruby/autoprefixer-rails/metadata.xml11
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/autoprefixer-rails/Manifest b/dev-ruby/autoprefixer-rails/Manifest
new file mode 100644
index 000000000000..e111b1826ccb
--- /dev/null
+++ b/dev-ruby/autoprefixer-rails/Manifest
@@ -0,0 +1 @@
+DIST autoprefixer-rails-6.7.3.gem 344576 SHA256 7c7d3b4b6d8d2f49fce2221ad9273ff774d61c43b6a96185dbafe69640a442fe SHA512 1477cdd74eaa9b166e81e6dbef0284cacc5d5c7f4d0156e653f21e664f7e730de6f95a3df89db3d4ec953738b953f9d7a4443d9674249030fbe3e7fabec56646 WHIRLPOOL c8b8a109f6a4021ecee040723e51ec241346ce3d82d9ea8376d0d36b0fa49b7631266ed53e67d17da76aa44a6317130465e2915ee04952c7557915617d03142e
diff --git a/dev-ruby/autoprefixer-rails/autoprefixer-rails-6.7.3.ebuild b/dev-ruby/autoprefixer-rails/autoprefixer-rails-6.7.3.ebuild
new file mode 100644
index 000000000000..c128b222b465
--- /dev/null
+++ b/dev-ruby/autoprefixer-rails/autoprefixer-rails-6.7.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add vendor prefixes to CSS rules using values from the Can I Use website"
+HOMEPAGE="https://github.com/ai/autoprefixer-rails"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="6"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/execjs:*"
+
+ruby_add_bdepend "dev-ruby/rails
+ dev-ruby/rake
+ dev-ruby/rspec-rails"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" -e "/BUNDLE/d" spec/app/config/boot.rb || die
+ sed -i -e "/Bundler/,+3d" spec/app/config/application.rb || die
+ rm spec/rails_spec.rb spec/compass_spec.rb || die
+}
diff --git a/dev-ruby/autoprefixer-rails/metadata.xml b/dev-ruby/autoprefixer-rails/metadata.xml
new file mode 100644
index 000000000000..e92f1085c453
--- /dev/null
+++ b/dev-ruby/autoprefixer-rails/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ai/autoprefixer-rails</remote-id>
+ </upstream>
+</pkgmetadata>