summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-01 00:16:55 +0100
committerSam James <sam@gentoo.org>2023-04-01 21:08:38 +0100
commit92c55db7881dcdc2c010461663d3740200f5272b (patch)
tree75327de458fe107cee47b436df18a7cc2a8d70c3 /dev-ruby/bcrypt-ruby
parentdev-ruby/ascii85: EAPI 8, enable ruby32 (diff)
downloadgentoo-92c55db7881dcdc2c010461663d3740200f5272b.tar.gz
gentoo-92c55db7881dcdc2c010461663d3740200f5272b.tar.bz2
gentoo-92c55db7881dcdc2c010461663d3740200f5272b.zip
dev-ruby/bcrypt-ruby: enable ruby32, fix indentation
- Enable ruby32 - Use <<- instead of << to strip whitespace which lets us have the necessary indentation without double-indenting/not-indenting-at-all (this preserves the indentation in the gemspec) - Add missing die in heredoc Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/bcrypt-ruby')
-rw-r--r--dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.18.ebuild44
1 files changed, 21 insertions, 23 deletions
diff --git a/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.18.ebuild b/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.18.ebuild
index c7938cd7693d..58da5a7621b9 100644
--- a/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.18.ebuild
+++ b/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.18.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -18,11 +18,10 @@ inherit ruby-fakegem
DESCRIPTION="An easy way to keep your users' passwords secure"
HOMEPAGE="https://github.com/codahale/bcrypt-ruby"
-LICENSE="MIT"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+LICENSE="MIT"
SLOT="0"
-IUSE=""
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
all_ruby_prepare() {
rm Gemfile || die
@@ -30,23 +29,22 @@ all_ruby_prepare() {
}
each_ruby_install() {
- each_fakegem_install
-
- # bcrypt was called bcrypt-ruby before, so add a spec file that
- # simply loads bcrypt to make sure that old projects load correctly
- # we don't even need to create a file to load this: the `require
- # bcrypt` was already part of bcrypt-ruby requirements.
- cat - <<EOF > "${T}/bcrypt-ruby.gemspec"
-Gem::Specification.new do |s|
- s.name = "bcrypt-ruby"
- s.version = "${RUBY_FAKEGEM_VERSION}"
- s.summary = "Fake gem to load bcrypt"
- s.homepage = "${HOMEPAGE}"
- s.specification_version = 3
- s.add_runtime_dependency("${RUBY_FAKEGEM_NAME}", ["= ${RUBY_FAKEGEM_VERSION}"])
-end
-EOF
- RUBY_FAKEGEM_NAME=bcrypt-ruby \
- RUBY_FAKEGEM_GEMSPEC="${T}/bcrypt-ruby.gemspec" \
- ruby_fakegem_install_gemspec
+ each_fakegem_install
+
+ # bcrypt was called bcrypt-ruby before, so add a spec file that
+ # simply loads bcrypt to make sure that old projects load correctly
+ # we don't even need to create a file to load this: the `require
+ # bcrypt` was already part of bcrypt-ruby requirements.
+ cat <<-EOF > "${T}/bcrypt-ruby.gemspec" || die
+ Gem::Specification.new do |s|
+ s.name = "bcrypt-ruby"
+ s.version = "${RUBY_FAKEGEM_VERSION}"
+ s.summary = "Fake gem to load bcrypt"
+ s.homepage = "${HOMEPAGE}"
+ s.specification_version = 3
+ s.add_runtime_dependency("${RUBY_FAKEGEM_NAME}", ["= ${RUBY_FAKEGEM_VERSION}"])
+ end
+ EOF
+
+ RUBY_FAKEGEM_NAME=bcrypt-ruby RUBY_FAKEGEM_GEMSPEC="${T}/bcrypt-ruby.gemspec" ruby_fakegem_install_gemspec
}