summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-02-27 07:50:57 +0100
committerHans de Graaff <graaff@gentoo.org>2017-02-27 07:51:37 +0100
commit4449849bf203bc73931e3d53333ac893fc89083c (patch)
tree1a30942e5ae2df814f6f058d016d4ead3dd40824 /dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild
parentdev-ruby/concurrent-ruby: cleanup (diff)
downloadgentoo-4449849bf203bc73931e3d53333ac893fc89083c.tar.gz
gentoo-4449849bf203bc73931e3d53333ac893fc89083c.tar.bz2
gentoo-4449849bf203bc73931e3d53333ac893fc89083c.zip
dev-ruby/bcrypt_pbkdf: initial import of 1.0.0
New test dependency for dev-ruby/net-ssh. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild')
-rw-r--r--dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild b/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild
new file mode 100644
index 000000000000..065650faf8cd
--- /dev/null
+++ b/dev-ruby/bcrypt_pbkdf/bcrypt_pbkdf-1.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements bcrypt_pdkfd (a variant of PBKDF2 with bcrypt-based PRF)"
+HOMEPAGE="https://github.com/net-ssh/bcrypt_pbkdf-ruby"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rbnacl )"
+
+all_ruby_prepare() {
+ # Don't use a ruby-bundled version of libsodium
+ sed -i -e '/rbnacl\/libsodium/ s:^:#:' test/bcrypt_pnkdf/engine_test.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/mri extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/mri
+ cp ext/mri/bcrypt_pbkdf_ext.so lib/ || die
+}