summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-07-13 08:12:34 +0200
committerHans de Graaff <graaff@gentoo.org>2019-07-13 08:13:30 +0200
commit574fa61946edb3aa132494d1d5cc37c36c063329 (patch)
tree085f00cbdbf9383e3037511f68fe444effaeb6bd /dev-ruby/bindex/bindex-0.8.1.ebuild
parentdev-ruby/bindata: add 2.4.4 (diff)
downloadgentoo-574fa61946edb3aa132494d1d5cc37c36c063329.tar.gz
gentoo-574fa61946edb3aa132494d1d5cc37c36c063329.tar.bz2
gentoo-574fa61946edb3aa132494d1d5cc37c36c063329.zip
dev-ruby/bindex: add 0.8.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/bindex/bindex-0.8.1.ebuild')
-rw-r--r--dev-ruby/bindex/bindex-0.8.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/bindex/bindex-0.8.1.ebuild b/dev-ruby/bindex/bindex-0.8.1.ebuild
new file mode 100644
index 000000000000..b4793d77304c
--- /dev/null
+++ b/dev-ruby/bindex/bindex-0.8.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Bindings for your Ruby exceptions"
+HOMEPAGE="https://github.com/gsamokovarov/bindex"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/skiptrace extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/skiptrace
+ cp ext/skiptrace/cruby.so lib/skiptrace/internal/ || die
+}